Closed Bug 1344760 Opened 3 years ago Closed 3 years ago

Sync preference page not loading

Categories

(Firefox :: Preferences, defect)

54 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
firefox51 --- unaffected
firefox52 --- unaffected
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 + verified
firefox55 --- verified

People

(Reporter: thesilentlink, Unassigned)

References

Details

(Keywords: nightly-community, regression)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170306030205

Steps to reproduce:

1. Load the preferences page
2. Click on Sync
3. Page doesn't change to the Sync preference page.


Actual results:

The page doesn't change to the Sync Preference page. It just stays the same.

Console output: https://pastebin.mozilla.org/8981173


Expected results:

The page should have changed to the Sync Preference page
Component: Untriaged → Preferences
Status: UNCONFIRMED → NEW
Ever confirmed: true
Confirmed on Linux, you need to be logged in into Sync to trigger the bug.
17:26.74 INFO: Last good revision: c5f07e7744d0ae707051ae57a2d9f642251bfc3f
17:26.74 INFO: First bad revision: 0bd17b868a31ce1e53b87f7a619974ad8c796f84
17:26.74 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=c5f07e7744d0ae707051ae57a2d9f642251bfc3f&tochange=0bd17b868a31ce1e53b87f7a619974ad8c796f84

17:27.94 INFO: Looks like the following bug has the  changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1335877
Gandalf, apparently this regression was caused by your patch in bug 1335877, could you have a look please? Thanks
Flags: needinfo?(gandalf)
Browser console log:
17:04:26,206 Error initializing preference category paneSync: TypeError: Str.sync.get is not a function 1 preferences.js:181
gotoPref chrome://browser/content/preferences/in-content/preferences.js:181:5
init_all/< chrome://browser/content/preferences/in-content/preferences.js:73:50
_fireOnSelect chrome://global/content/bindings/richlistbox.xml:78:13
selectItem chrome://global/content/bindings/listbox.xml:247:11
onxblmousedown chrome://global/content/bindings/listbox.xml:979:13

17:04:26,206 TypeError: Str.sync.get is not a function 1 util.js:708:12
getDefaultDeviceName resource://services-sync/util.js:708:12
_populateComputerName chrome://browser/content/preferences/in-content/sync.js:499:28
_showLoadPage chrome://browser/content/preferences/in-content/sync.js:94:5
updateWeavePrefs chrome://browser/content/preferences/in-content/sync.js:260:5
_init chrome://browser/content/preferences/in-content/sync.js:139:5
init chrome://browser/content/preferences/in-content/sync.js:49:7
init chrome://browser/content/preferences/in-content/preferences.js:47:7
init_category_if_required chrome://browser/content/preferences/in-content/preferences.js:40:3
gotoPref chrome://browser/content/preferences/in-content/preferences.js:179:5
init_all/< chrome://browser/content/preferences/in-content/preferences.js:73:50
_fireOnSelect chrome://global/content/bindings/richlistbox.xml:78:13
selectItem chrome://global/content/bindings/listbox.xml:247:11
onxblmousedown chrome://global/content/bindings/listbox.xml:979:13
Oh, apologies for causing the bug! Thank you for reporting it and backing out my faulty patch.

Will work on the fix in bug 1335877.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(gandalf)
Resolution: --- → FIXED
Updating tracking flags so this falls off the release health dashboard.
:TheSilentLink, thank you for your report!

I am the original author of the patch that caused the bug. I fixed the bug you discovered and tested the fix against the STR you provided (see bug 1335877 comment 22).

It means that with tomorrow build it should work as expected. If you will see the same bug, please let me know.
I can confirm the bug is now fixed.

Thanks
Duplicate of this bug: 1345028
Flags: qe-verify+
Reproduced on 54.0a1 (2017-03-06) Win 10.
Verified fixed 55.0a1 (2017-04-28), 54b3 on Win 10, Ubuntu 14.04, OS X 10.11.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.