Closed Bug 1344900 Opened 3 years ago Closed 3 years ago

CSS touchups for Synced Tabs when Tab Syncing disabled

Categories

(Firefox :: Sync, defect, P3)

Unspecified
macOS
defect

Tracking

()

VERIFIED FIXED
Firefox 55
Tracking Status
firefox55 --- verified

People

(Reporter: eoger, Assigned: kurshakovakristina, Mentored)

Details

(Keywords: good-first-bug)

Attachments

(4 files)

Attached image tofix_intoolbar.png
When the synced tabs button is put in the toolbar, and open tabs syncing is disabled, the "Sync preferences" button is not aligned (and neither the sync illustration I think). (see tofix_intoolbar.png)
The problem arises too when the synced tabs button is in the hamburger menu, but too a lesser extent. (see tofix_inpanel.png)
We have to be careful when fixing this, because the non-signed in view, which doesn't have this alignment problem, could be affected (see signin).
Attached image tofix_inpanel.png
Attached image signin.png
Mentor: eoger
Keywords: good-first-bug
Priority: -- → P3
Hi,

I do not see this problem in Linux. Are you sure there is a problem with it?
Good find, I tried on Ubuntu and Windows and couldn't reproduce. Marking this but as MacOS only.
OS: Unspecified → Mac OS X
Hey, I think I fixed the bug. Can someone assign this bug to me?
(In reply to Kristina Kurshakova from comment #5)
> Hey, I think I fixed the bug. Can someone assign this bug to me?

Done!
Assignee: nobody → kurshakovakristina
Hi there, I pushed my fix, could you help me with the next step?
Flags: needinfo?(eoger)
Comment on attachment 8859686 [details]
Bug 1344900 - Center remote tabs panel when tab syncing disabled.

https://reviewboard.mozilla.org/r/131704/#review134494

Well I must say I wasn't expecting a one-line-patch for this :)
I also tested this on Windows and I didn't notice any regression.
Thank you for the patch, please fix the commit message and I'll land this for you.

::: commit-message-ef8d1:1
(Diff revision 1)
> +Bug 1344900 - Toolbar -> Synced Tabs -> "Sync Preferences" align button to center

Reword this to "Bug 1344900 - Center remote tabs panel when tab syncing disabled. r?eoger"
Attachment #8859686 - Flags: review+
Comment on attachment 8859686 [details]
Bug 1344900 - Center remote tabs panel when tab syncing disabled.

https://reviewboard.mozilla.org/r/131704/#review134494

Thanks Edouard! I'm done with commit message.
Pushed by eoger@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/79d38eed0b73
Center remote tabs panel when tab syncing disabled. r=eoger
https://hg.mozilla.org/mozilla-central/rev/79d38eed0b73
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
And it's merged! Thank you for your contribution Kristina.
Flags: needinfo?(eoger)
@Eduardo Cool! Thanks guys for assisting my first bug!
I managed to reproduce this bug on Nightly from 2017-03-06 using Mac OS x 10.11. I retested it on the latest Nightly and Firefox 55.0b13 using the same platform and the bug is not reproducing anymore. I think that it's fixed.
Thanks Oana, I'll mark this as verified fixed based on your testing.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.