Closed Bug 1344901 Opened 3 years ago Closed 3 years ago

Fix a regression from bug 1337551

Categories

(Core :: Internationalization, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox54 --- fixed
firefox55 --- fixed

People

(Reporter: zbraniecki, Assigned: zbraniecki)

References

Details

Attachments

(1 file)

I just landed bug 1337551 and noticed that I called `GetSystemLocale()` in it, while our API has `GetSystemLocales()` and `systemLocale` property.
Assignee: nobody → gandalf
Status: NEW → ASSIGNED
We may have to backport it to aurora since today is the merge day.
Comment on attachment 8844172 [details]
Bug 1344901 - Fix a regression introduced in bug 1337551.

https://reviewboard.mozilla.org/r/117704/#review119404

Oops!
Attachment #8844172 - Flags: review?(jfkthame) → review+
Comment on attachment 8844172 [details]
Bug 1344901 - Fix a regression introduced in bug 1337551.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1337551
[User impact if declined]: in some scenarios, users who want to match their locale to the OS will not be able too. There may also be exceptions.
[Is this code covered by automated tests?]: badly as indicated by the fact that I landed the regression green.
[Has the fix been verified in Nightly?]: Yep.
[Needs manual test from QE? If yes, steps to reproduce]: No, I tested it locally
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: no
[Why is the change risky/not risky?]: Because it's a trivial change of the property name in 4 places from a property that doesn't exist, to one that does.
[String changes made/needed]: None
Attachment #8844172 - Flags: approval-mozilla-aurora?
Duplicate of this bug: 1344978
Blocks: 1337551
Pushed by zbraniecki@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e1b9ef9ab95d
Fix a regression introduced in bug 1337551. r=jfkthame
Hi :zibi,
Since yesterday was merge day, I'm not sure if you request for Beta53 or Aurora54 uplift? If you want to request for 53, you can create another Beta53 uplift request.
Flags: needinfo?(gandalf)
https://hg.mozilla.org/mozilla-central/rev/e1b9ef9ab95d
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
:gchang, yes, this is for 54, sorry for confusion!
Flags: needinfo?(gandalf)
Duplicate of this bug: 1344727
Comment on attachment 8844172 [details]
Bug 1344901 - Fix a regression introduced in bug 1337551.

Fix a regression. Aurora54+.
Attachment #8844172 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.