Mechanism to exclude non-NEON versions

RESOLVED FIXED

Status

()

Firefox for Android
General
RESOLVED FIXED
a year ago
10 months ago

People

(Reporter: lizzard, Assigned: lizzard)

Tracking

(Blocks: 1 bug)

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox53+ fixed)

Details

Reminder to exclude non-NEON ARM devices from updating to 53 on the Play Store for 53 release as we are doing with 53 beta. Here is the current list of devices to exclude:

Motorola Atrix 4G: qinara, olympus
DROIDX2
Motorola Photon– asanti_c, sunfire
LGEOptimus 2X– p990, p999
Samsung Galaxy R, (jaguarl, jaguars, jaguark)
Samsung Captivate Glide
MotorolaXOOM– wifi_hubble, umts_everest
Sony Tablet S
Dell Streak 7
Asus Slider
Olivetti OliPad 100
ASUS Eee Pad Transformer 
Samsung Galaxy Tab 10.1
Hannspree Hannspad

+++ This bug was initially created as a clone of Bug #1305815 +++

We are dropping support for non-NEON ARM, and we need something in place to either warn people at run time, or stop them from downloading the version that won't run, or some combination of both.
(Assignee)

Updated

a year ago
Assignee: nobody → lhenry
status-firefox53: --- → affected
tracking-firefox53: --- → +

Updated

a year ago
Duplicate of this bug: 1343906
(Assignee)

Comment 2

a year ago
This is done for 53 release in the Play Store.
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox53: affected → fixed
Resolution: --- → FIXED
Liz do you see an entry for Asus SL101 if so would you add it to the blocked list? https://www.asus.com/us/Tablets/Eee_Pad_Slider_SL101/
Flags: needinfo?(lhenry)
(In reply to Kevin Brosnan [:kbrosnan] from comment #3)
> Liz do you see an entry for Asus SL101 if so would you add it to the blocked
> list? https://www.asus.com/us/Tablets/Eee_Pad_Slider_SL101/

"Asus Eee Pad Slider - SL101" added to the blocked list for release; looks like it was already blocked on beta.
Flags: needinfo?(lhenry)
Is there an entry for Toshiba AT105/16 ?
Flags: needinfo?(jcristau)
(Assignee)

Comment 6

a year ago
No, I don't see it. But there are some variants, like "Toshiba CorporationAT10-A/AT15-A (Japan: AT503)– tostab12BL"
That looks to be Tegra 3 which has Neon. Thanks for checking. It looks like the correct model number is AT105-T1016 for the Tegra 2 version.
Flags: needinfo?(jcristau)
Looking at other toshiba products I can see
- "Toshiba Thrive 7" which according to http://www.gsmarena.com/toshiba_thrive_7-4203.php is tegra2
- "Toshiba AT100", http://www.toshiba.co.uk/discontinued-products/toshiba-at100-100/
Just to close the loop, we should block those. If you already have then great!
Blocked Toshiba Thrive 7 and Toshiba AT100. I didn't see AT105-T1016 in any of the devices listed, so I couldn't block it.

Comment 11

10 months ago
Sony Tablet P is also missing from this list.
(Assignee)

Comment 12

10 months ago
(In reply to james.haggerty from comment #11)
> Sony Tablet P is also missing from this list.

Thanks james. I just double checked, and it looks like we block Sony Tablet P on release already.  Are you able to download the current version of Firefox from the Play Store?
Flags: needinfo?(james.haggerty)

Comment 13

10 months ago
Yes, I can install 55.0.2 from the Play Store, and get the message "Sorry! Firefox won't work on this device (armeabi-v7a, 15). Please download the correct version."

I assumed it was because it was missing from the list quoted above (first comment in this thread).
Flags: needinfo?(james.haggerty)
(Assignee)

Comment 14

10 months ago
Hmm. It's listed as "unsupported" rather than "excluded". I had assumed unsupported meant you cannot download it. I can't add it to the list of excluded devices since it's detected as unsupported. So it must have some other incompatibility detected by the Play Store.

You might try running Firefox 52 (https://archive.mozilla.org/pub/mobile/releases/52.0.2/android-api-15/multi/) which I think is the last compatible version for devices with non-NEON hardware.

Comment 15

10 months ago
Hmm, how odd. Thanks for pointing me to the archive; I ended up building my own version of Firefox 55 with disabled NEON support, which seem to work fine (https://github.com/wryun/firefox-ics-tegra2/releases).
You need to log in before you can comment on or make changes to this bug.