Need to know when Windows is configured to color the title bars

RESOLVED FIXED in Firefox 56

Status

()

P1
normal
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: mconley, Assigned: jwatt)

Tracking

({dev-doc-complete})

unspecified
mozilla56
dev-doc-complete
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox56 fixed)

Details

(Whiteboard: [photon-visual][p1][tpi:+])

Attachments

(2 attachments, 2 obsolete attachments)

In Windows 10 (and perhaps lower), there's a user setting for putting an accent colour in the title bar of windowed applications.

For proper integration, we should detect that setting and colour our title bar appropriately.

Updated

2 years ago
Priority: -- → P3
Whiteboard: tpi:+
Dao: it's not clear we have a bug to actually use this info in the theme (similarly for bug 1344910), can we get that filed w/ relevant UX spec?
Flags: needinfo?(dao+bmo)
Yep, will do.
Flags: needinfo?(dao+bmo)
Blocks: 1196266
No longer blocks: 1325171

Updated

2 years ago
Priority: P3 → P1
Whiteboard: tpi:+ → [tpi:+][photon]
Whiteboard: [tpi:+][photon] → [tpi:+][photon-visual]
Flags: qe-verify-
Priority: P1 → P2
Whiteboard: [tpi:+][photon-visual] → [photon-visual][p1][tpi:+]
(Assignee)

Updated

2 years ago
Assignee: nobody → jwatt
Status: NEW → ASSIGNED
Priority: P2 → P1
(Assignee)

Comment 3

2 years ago
Created attachment 8879765 [details] [diff] [review]
part 1 - Implement a '-moz-windows-accent-color-applies' media query
Attachment #8879765 - Flags: review?(cam)
(Assignee)

Comment 4

2 years ago
Created attachment 8879766 [details] [diff] [review]
part 2 - Add some tests for the '-moz-windows-accent-color-applies' media query
Attachment #8879766 - Flags: review?(cam)
Attachment #8879765 - Flags: review?(cam) → review+
Attachment #8879766 - Flags: review?(cam) → review+

Comment 5

2 years ago
Pushed by jwatt@jwatt.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/352c30687dea
part 1 - Add a '-moz-windows-accent-color-applies' media query. r=heycam
https://hg.mozilla.org/integration/mozilla-inbound/rev/b1e72c299049
part 2 - Add tests for the '-moz-windows-accent-color-applies' media query. r=heycam
(Assignee)

Comment 8

2 years ago
That crash wasn't caused by the patches here (it was caused by the patch for bug 1369508). That said, this bug did cause tier 2 stylo failures. Simon has written a stylo patch to fix those issues at https://github.com/servo/servo/pull/17449/ and once that has the necessary reviews we can reland this patch and that one together.
Flags: needinfo?(jwatt)
(Assignee)

Comment 9

2 years ago
Because these changes need to be synchronized with Servo changes it seems like I'll need to use MozReview so that I can land using Autoland. I'll put up MozReview patches and r+ them ready for landing shortly.
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 12

2 years ago
mozreview-review
Comment on attachment 8881623 [details]
Bug 1344917, part 1 - Add a '-moz-windows-accent-color-applies' media query.

https://reviewboard.mozilla.org/r/152786/#review157908
Attachment #8881623 - Flags: review?(cam) → review+

Comment 13

2 years ago
mozreview-review
Comment on attachment 8881624 [details]
Bug 1344917, part 2 - Add tests for the '-moz-windows-accent-color-applies' media query.

https://reviewboard.mozilla.org/r/152788/#review157910
Attachment #8881624 - Flags: review?(cam) → review+
(Assignee)

Updated

2 years ago
Attachment #8879765 - Attachment is obsolete: true
(Assignee)

Updated

2 years ago
Attachment #8879766 - Attachment is obsolete: true

Comment 14

2 years ago
Pushed by ecoal95@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d07b25fd6533
part 1 - Add a '-moz-windows-accent-color-applies' media query. r=heycam
https://hg.mozilla.org/integration/autoland/rev/d7dca95a5bc8
part 2 - Add tests for the '-moz-windows-accent-color-applies' media query. r=heycam

Comment 15

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/d07b25fd6533
https://hg.mozilla.org/mozilla-central/rev/d7dca95a5bc8
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56

Comment 16

2 years ago
sorry for asking but why is it even needed for firefox to know the system color or anything, I mean how did firefox never have a problem in older OSes than windows 10? and why not use that way?
Iteration: --- → 56.2 - Jul 10
This is documented; see https://bugzilla.mozilla.org/show_bug.cgi?id=1344910#c27
Keywords: dev-doc-complete
You need to log in before you can comment on or make changes to this bug.