Support bitwarden password manager app extension

RESOLVED FIXED

Status

()

P2
normal
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: kyle.spearrin, Unassigned)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios+)

Details

(Whiteboard: [MobileCore])

Attachments

(1 attachment)

55 bytes, text/x-github-pull-request
jhugman
: review+
Details | Review | Splinter Review
(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

- Install bitwarden password manager app: https://bitwarden.com
- Enable bitwarden app extension from bitwarden "Tools" screen
- In Firefox, tap share icon to open share menu
- Tap bitwarden password manager app extension



Actual results:

Injected Javascript file from app extension is not executed, therefore no page details can be gathered to perform an autofill.


Expected results:

Injected Javascript from extension is executed so that page details can be gathered for autofill.
(Reporter)

Comment 1

2 years ago
Created attachment 8844305 [details] [review]
Pull request
(Reporter)

Updated

2 years ago
Attachment #8844305 - Flags: review?(sleroux)
Status: UNCONFIRMED → NEW
tracking-fxios: --- → ?
Ever confirmed: true
Comment on attachment 8844305 [details] [review]
Pull request

Thanks for the patch Kyle! I'm going to forward to James who has handled the password manager stuff in the past.
Attachment #8844305 - Flags: review?(sleroux) → review?(jhugman)
tracking-fxios: ? → +
Priority: -- → P2
Whiteboard: [MobileCore]
Comment on attachment 8844305 [details] [review]
Pull request

Reviewed, approved and merged. 

Thank you so much for your contribution!
Attachment #8844305 - Flags: review?(jhugman) → review+
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

a year ago
Hey guys,
How do I figure out what production version this PR is targeted to? I'm trying to test this with the version in the app store today  (7.3, 2772) and I cannot get it working.
Hey Kyle

Looks like this didn't make the cut for 7.x, as per

https://github.com/kspearrin/firefox-ios/blob/v7.x/Client/Frontend/Share/ShareExtensionHelper.swift#L126

It's on master currently so it should be released with 8.0, which is entering the beta period shortly.
(Reporter)

Comment 6

a year ago
Thanks Aaron! I'll stop chasing Ghost bugs now :)
You need to log in before you can comment on or make changes to this bug.