Sync category in preferences does not diplay

RESOLVED DUPLICATE of bug 1344760

Status

()

RESOLVED DUPLICATE of bug 1344760
2 years ago
2 years ago

People

(Reporter: MikkCZ, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nightly-community])

Mozilla/5.0 (X11; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0 ID:20170306110339 CSet: 966464a68a2cb3ca1125808e34abb5c1d34e3797

> Error initializing preference category paneSync: TypeError: Str.sync.get is not a function  preferences.js:181
>	gotoPref chrome://browser/content/preferences/in-content/preferences.js:181:5
>	init_all/< chrome://browser/content/preferences/in-content/preferences.js:73:50
>	_fireOnSelect chrome://global/content/bindings/richlistbox.xml:78:13
>	selectItem chrome://global/content/bindings/listbox.xml:247:11
>	onxblmousedown chrome://global/content/bindings/listbox.xml:979:13
> TypeError: Str.sync.get is not a function[Zjistit více]  util.js:708:12
>	getDefaultDeviceName resource://services-sync/util.js:708:12
>	_populateComputerName chrome://browser/content/preferences/in-content/sync.js:499:28
>	_showLoadPage chrome://browser/content/preferences/in-content/sync.js:94:5
>	updateWeavePrefs chrome://browser/content/preferences/in-content/sync.js:260:5
>	_init chrome://browser/content/preferences/in-content/sync.js:139:5
>	init chrome://browser/content/preferences/in-content/sync.js:49:7
>	init chrome://browser/content/preferences/in-content/preferences.js:47:7
>	init_category_if_required chrome://browser/content/preferences/in-content/preferences.js:40:3
>	gotoPref chrome://browser/content/preferences/in-content/preferences.js:179:5
>	init_all/< chrome://browser/content/preferences/in-content/preferences.js:73:50
>	_fireOnSelect chrome://global/content/bindings/richlistbox.xml:78:13
>	selectItem chrome://global/content/bindings/listbox.xml:247:11
>	onxblmousedown chrome://global/content/bindings/listbox.xml:979:13

I will make a bisection later today and verify, if it does not affect the Czech version only.
Whiteboard: [nightly-community]
The English version is also affected, but only when Sync account is set up. Will take me more time to find the bisection. :(

For the English version
> TypeError: Str.sync.get is not a function[Zjistit více]  util.js:708:12
is
> TypeError: Str.sync.get is not a function[Learn More]  util.js:708:12
Thanks Michal, we filed it yesterday :)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1344760
You need to log in before you can comment on or make changes to this bug.