Mac installer fails confusingly if Netscape 4.x is running

VERIFIED WONTFIX

Status

VERIFIED WONTFIX
17 years ago
14 years ago

People

(Reporter: mpt, Assigned: slogan)

Tracking

({regression})

Trunk
PowerPC
Mac System 9.x
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build: full installer, Mac OS 9.2

To reproduce:
1.  Start Netscape Communicator 4.x, along with any other apps of your choice,
    (not including Mozilla or Netscape 6.x).
2.  Start the Mozilla installer.
3.  Select your options etc, and click the `Install' button.

What happens:
*   An extremely ugly alert appears (gray title bar which should be pink,
    white background which should be gray, System-7.x-style icon which should
    be System-8/9-style, etc).
*   The alert complains that another version of `this application' (which
    application?) is running, which isn't true.
*   The alert tells the user to quit that other version, rather than offering
    to do it itself, which is especially perplexing since the user isn't
    running any other version of Mozilla, so he/she will have no idea which
    application the alert is talking about.
*   The `Continue' button is enabled even if the mysterious offending
    application hasn't been quit yet, and makes a `ding!' noise when clicked.

What should happen:
*   The installer just installs Mozilla already, without complaining.
*   Failing that, half a dozen bugs should be filed on fixing up the alert.

This is a regression. See also bug 110877, which applies to Netscape 6.x 
browsers.
Syd gets it since he caused it, this is exactly what I was talking about in bug
110888 comment 14. (Although the check-in referenced bug 110877, that's a meta
bug and the real fix that regressed this was bug 110888).

See also related bug 87349 which may have been fixed by the 110888 checkin,
depending on the wording used.
Assignee: dveditz → syd
Keywords: regression

Updated

17 years ago
QA Contact: bugzilla → ktrina

Comment 2

17 years ago
Same here 8.6. 

Comment 3

16 years ago
Quoth Steve Dagley: "The Mac installer code was never Carbonized and there is no
intention to ever change that."

http://groups.google.com/groups?threadm=yahoo_com-77F6E8.09344011022003%40h-204-29-187-156.netscape.com
http://groups.google.com/groups?threadm=avkj4k%24ihs2%40ripley.netscape.com
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 4

16 years ago
Verified wontfix
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.