URL completion leads to bestiality site?

RESOLVED INVALID

Status

SeaMonkey
Location Bar
--
trivial
RESOLVED INVALID
16 years ago
10 years ago

People

(Reporter: Bo Brinkman, Assigned: Joe Hewitt (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-22smp i686; en-US; m18)
Gecko/20010110 Netscape6/6.5
BuildID:    2001122108

I wanted to find out which release of mozilla I was running. Since I don't know
the build-id => version mapping, I thought I would try the URL "version:" on the
off chance that it would work like "about:" but give me the information I wanted.

What happened was the "version:" got auto-munged into "www.version.com" which is
a site that redirects to www.farmgirls.com, a bestiality pornography site, and
is exceedingly disgusting. 

Perhaps if mozilla sees something that looks like a mozilla internal URL, it
shouldn't auto-munge it? And also, for release versions, why isn't the version
number (like 0.9.8) included in the "about:" page?

Not exactlya bug, really, but maybe more of a policy decision.

Reproducible: Always
Steps to Reproduce:
1. Enter "version:" in the URL bar, hit enter.


Actual Results:  End up at www.farmgirls.com (after being redirected from
www.version.com)

Expected Results:  Error, or show an internal page summarizing the mozilla
version currently in use.
we can't protect you from this sites and you can use Help/About Mozilla

and you should see there a version string if you haven't disabled Javascript.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.