Closed Bug 1345190 Opened 3 years ago Closed 3 years ago

disable stylo builds and tests on m-a

Categories

(Infrastructure & Operations :: CIDuty, task)

task
Not set

Tracking

(firefox55 fixed)

RESOLVED FIXED
Tracking Status
firefox55 --- fixed

People

(Reporter: kmoir, Assigned: kmoir)

Details

Attachments

(1 file)

Noticed that they were running on m-a after the merge.  Talked to the quantum team today and verified that they should not be running.
Assignee: nobody → kmoir
I found the problem here

The builds for stylo have run on projects enabled in  ci/build/linux.yml 

run-on-projects: [ 'stylo', 'autoland', 'mozilla-inbound', 'mozilla-central' ]

However, the non-reftests tests do not.  So if you look at the target-tasks.graph for m-a these tests are still listed

https://treeherder.mozilla.org/#/jobs?repo=mozilla-aurora&selectedJob=82117307

https://public-artifacts.taskcluster.net/HVCYIo_OSo2XYWZ3Qka2yw/0/public/target-tasks.json

such as
test-linux64-stylo/debug-cppunit",

So the tests jobs run which I assume requires triggers the build even though it's not in the target task graph.  In any case, I'm going to add branch restrictions to these tests in ci/test/tests.yml
Attached patch bug1345190.patchSplinter Review
Attachment #8844577 - Flags: review?(aki)
Comment on attachment 8844577 [details] [diff] [review]
bug1345190.patch

|./mach taskgraph optimized --json -p auroraparams.yml > dirty.json| gave me no stylo tests, while doing it sans patch gave me stylo tests.  lgtm.
Attachment #8844577 - Flags: review?(aki) → review+
Pushed by kmoir@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5762a99118ed
disable stylo builds and tests on m-a r=aki DONTBUILD
Comment on attachment 8844577 [details] [diff] [review]
bug1345190.patch

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1345190
[User impact if declined]: stylo builds + tests running on m-a and don't need to be there, wasting aws resources + $$$
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: n/a, stylo builds are separate from nightly
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: n/a
[Is the change risky?]: no
[Why is the change risky/not risky?]: just turns off some tests and stylo builds which aren't needed on m/a
[String changes made/needed]:
Attachment #8844577 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/5762a99118ed
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Still have to uplift to m-a
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 8844577 [details] [diff] [review]
bug1345190.patch

Since it doesn't impact anything we're shipping I don't think I need relman approval.  I just landed it on m-a
Attachment #8844577 - Flags: approval-mozilla-aurora? → checked-in+
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Component: Platform Support → Buildduty
Product: Release Engineering → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.