"Select a Device" missing from Responsive Design Mode

RESOLVED INVALID

Status

()

Firefox
Developer Tools: Responsive Design Mode
RESOLVED INVALID
8 months ago
8 months ago

People

(Reporter: thumbsoup, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

8 months ago
Created attachment 8844561 [details]
Missing Select a Device in UI in Responsive Design Mode.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170302120751

Steps to reproduce:

1. go to any website such as https://news.ycombinator.com/

2. In Firefox, go to Tools, then Web Developer, then select Responsive Design Mode

3. There is no "Select a Device" control shown. That whole bar which is supposed to appear above the viewport does not display for me.

4. I tried this again in Firefox Safe Mode, with add ons disabled, and it still occurs.


Actual results:

"Select a Device" feature does not display.  I just learned about this feature from the Firefox Developer Tools page for Responsive Design Mode:

https://developer.mozilla.org/en-US/docs/Tools/Responsive_Design_Mode



Expected results:

According to Firefox Developer tools documentation, I should have seen:

"Just above the viewport you'll see a label "no device selected": click this to see a list of device names. Select a device, and Responsive Design Mode will set the following properties to match the selected device..."

Comment 1

8 months ago
I tested FF52, it works for me, see my screenshot: http://i.imgur.com/pWPvAyt.jpg
But I see you have the old RDM layout, because you disabled e10s. Could you test with e10s enabled (about:config > browser.tabs.remote.autostart=true).
Component: Untriaged → Developer Tools: Responsive Design Mode
Flags: needinfo?(thumbsoup)
(Reporter)

Comment 2

8 months ago
Thanks for responding. I changed that configuration to True. Still get problem.  However, in my Config, there are 2 entries for that setting? I don't know if that matters.

browser.tabs.remote.autostart

and then another right below it, with the number 2 as a suffix at the end.  This is ALSO set to True.

browser.tabs.remote.autostart.2

Comment 3

8 months ago
What do you have for the line "multiprocess windows" in about:support?

By default, e10s is enabled in a fresh profile with browser.tabs.remote.autostart=false (e10s disabled by user) and browser.tabs.remote.autostart.2=true (e10s enabled by default).
If you force browser.tabs.remote.autostart=true, e10s will be set as enabled by the user.

Updated

8 months ago
Depends on: 1345592

Comment 4

8 months ago
In addition, could you add a screenshot of RDM with e10s enabled.
Depends on: 1345515
No longer depends on: 1345592
Here's an additional support doc about multiprocess support:

https://support.mozilla.org/t5/Manage-preferences-and-add-ons/Enable-multiprocess-support/ta-p/1371917
(Reporter)

Comment 6

8 months ago
Created attachment 8845494 [details]
about config Firefox 3-9-2017.png
(Reporter)

Comment 7

8 months ago
Created attachment 8845495 [details]
Responsive Design Mode example Firefox 52 3-9-2017.png
(Reporter)

Comment 8

8 months ago
1. Multiprocess windows is Disabled by plugin in about:support

2. attached 2 screenshots.  My about:config, and then RDM example

3. I read doc on Multiprocess support (thanks).  The setting in about:config to Force it, I don't see in my about:config.  

I will try adding it manually, see what happens.
(Reporter)

Comment 9

8 months ago
Created attachment 8845501 [details]
Responsive Design Mode after force multiprocess support Firefox 52 3-9-2017.png
(Reporter)

Comment 10

8 months ago
RDM seems to work for me, after Force multiprocess support by adding Preference to about:config, and setting boolean to True.

See screenshot.

Thanks very much for your help, guys.  

Maybe this stays fixed?
Great, this sounds like it's working "as expected", but I am sorry it was so surprising / confusing!

We're working in bug 1345515 to make the situation more obvious for the future.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Flags: needinfo?(thumbsoup)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.