Closed Bug 1345247 Opened 4 years ago Closed 4 years ago

Devirtualize nsFrameSelection

Categories

(Core :: DOM: Selection, enhancement)

enhancement
Not set
minor

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: mats, Assigned: mats)

References

Details

Attachments

(1 file)

This class is final and has no base classes so I think we can
make its remaining virtual methods non-virtual now.
Attached patch fixSplinter Review
FYI, I'm removing the "class nsIScrollableFrame;" line because there's
an identical line a little later in this file.
Attachment #8844634 - Flags: review?(dholbert)
Comment on attachment 8844634 [details] [diff] [review]
fix

Review of attachment 8844634 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks! r=me
Attachment #8844634 - Flags: review?(dholbert) → review+
Pushed by mpalmgren@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5489cbc85d06
Devirtualize nsFrameSelection.  r=dholbert
https://hg.mozilla.org/mozilla-central/rev/5489cbc85d06
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Duplicate of this bug: 658750
You need to log in before you can comment on or make changes to this bug.