WASM Zen Garden demo causing errors Fx52, Fx55 - desktop/Android

RESOLVED INVALID

Status

()

--
critical
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: davross, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170307111623

Steps to reproduce:

Dell Latitude E4300, Arch Linux, Fx 52, Fx 55
Samsung Galaxy Tab A, Android Marshmallow 6.1, Fx55 (Fx 52 not in Google Play yet)

via David Bryant's Medium post https://medium.com/mozilla-tech/why-webassembly-is-a-game-changer-for-the-web-and-a-source-of-pride-for-mozilla-and-firfox-dda80e4c43cb he recommends to check Zen Garden.  http://s3.amazonaws.com/mozilla-games/ZenGarden/EpicZenGarden.html


Actual results:

All versions of desktop Firefox report error "Your browser does not support WebGL 2. Please try with Firefox 52 or newer."

On checking https://get.webgl.org/ the test runs as expected showing I have WebGL activated. Can't find specific v2 test :/

On Android this URL causes Firefox to crash. Tested 3 times.

No Zen felt.


Expected results:

Immersion in a Garden of Zen. Youtube version will have to do me for now.
(Reporter)

Updated

2 years ago
Summary: Your browser does not support WebGL 2. Please try with Firefox 52 or newer. → WASM Zen Garden demo causing errors Fx52, Fx55 - desktop/Android

Updated

2 years ago
Severity: normal → critical
Component: Untriaged → Canvas: WebGL
Product: Firefox → Core
For desktop version, WebGL2 requires OpenGL ES3.0 or OpenGL 3.2 support.
https://wiki.mozilla.org/Platform/GFX/WebGL2

Dell Latitude E4300 uses GMA4500MHD which support up to OpenGL2.0 is insufficient for WebGL2.

So unfortunately we cannot support it on your laptop.
(Reporter)

Comment 2

2 years ago
Ah thanks, really appreciate everyone's efforts in helping with this. This same issue comes up in testing Servo. I can force that through in terminal with `LIBGL_ALWAYS_SOFTWARE=1`. 3D rendering an issue back in 90's, sad we're still there with hardware today.

Tested further using https://www.khronos.org/registry/webgl/sdk/tests/webgl-conformance-tests.html?version=2.0.1 This version of the test immediately throws unsupported browser warning on latop :( But on the 'Samsung Galaxy Tab A' it's hit a few test errors, mostly to do with memory errors, and ultimately it's cause Fx55 to crash. So I guess my hardware is just not up to the task here. Here's where it helps being a Stoic!

I've some concern with the terminology used in these warnings, even the Khronos site stating "This browser does not appear to support the selected version of WebGL". This suggests blame on the browser and a trigger point for people to switch browser, when it's low-end hardware to blame. 

Proudly closing because my reconditioned tech is still good enough for me to save from the scrap heap.
(Reporter)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

2 years ago
On the tablet I tested in Samsung's browser and in Chrome. The unsupported browser flags. In Firefox (51.03 and 55.0) there is no warning flag and I can proceed to the test. Where it crashes in both. Filling crash reports direct from crash pop-up with reference back to this bug report.
You need to log in before you can comment on or make changes to this bug.