FF crashes after update from 51 to 52 on Ubuntu 16.04

RESOLVED DUPLICATE of bug 1345413

Status

()

--
blocker
RESOLVED DUPLICATE of bug 1345413
2 years ago
2 years ago

People

(Reporter: daniel.musketa, Unassigned)

Tracking

({crash})

52 Branch
Unspecified
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-50b93881-7cf2-493d-a495-fc7b42170308.
=============================================================

After the update from 

firefox:amd64 51.0.1+build2-0ubuntu0.16.04.2 to 52.0+build2-0ubuntu0.16.04.1

on Ubuntu 16.04 LTS Firefox doesn't start anymore but shows the crash report dialog instead. On the terminal we get 

    ExceptionHandler::GenerateDump cloned child 8129
    ExceptionHandler::SendContinueSignalToChild sent continue signal to child
    ExceptionHandler::WaitForContinueSignal waiting for continue signal...
    Speicherzugriffsfehler (Speicherabzug geschrieben)


This happens to all users and also after removing ~/.mozilla

Comment 1

2 years ago
I am also getting a crash every time the new FF 52 is started.  It is only happening through Xrdp.  FF 52 does come up on the main physical console of the Ubuntu 16 system however, that is not accessible for all users.  Nightly does come up correctly through build 2017-03-07. With this production outage, I am not refreshing Nightly as it is temporarily my primary window to the internet.

Comment 2

2 years ago
I'm getting this as well. I've tried safe mode.

Tried firefox-trunk as well, giving me a seg fault.

Comment 3

2 years ago
Confirmed on my end too. Crashes (normal and safe mode) via xRDP only after upgrading from 51 to 52 on Ubuntu 16.04. 

Downloaded the 51.0 tar package and firefox 51.0 loads without any issues.

Comment 4

2 years ago
[Tracking Requested - why for this release]:
Users can't start Firefox


Reporters/commenters: These look like Ubuntu builds. Does the same thing happen if you download a binary off https://www.mozilla.org/ ?

Chris, are you aware of any issues filed against Ubuntu?

:jcristau: flagging this up for relman attention.
tracking-firefox52: --- → ?
Flags: needinfo?(jcristau)
Flags: needinfo?(chrisccoulson)
Keywords: crash

Comment 5

2 years ago
Yes, this is bug 1345413
Flags: needinfo?(chrisccoulson)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1345413

Comment 7

2 years ago
I have the same problem with xrdp and firefox.

The workaround is to start with option -u username...

$ firefox -u $(id -un)

or set LOGNAME in your environment.

$ export LOGNAME=$(id -un)
$ firefox
Tracking in the other bug.  We should get that fixed in a 52 dot release.
tracking-firefox52: ? → ---
Flags: needinfo?(jcristau)

Comment 9

2 years ago
This is working since FF 52.0.2 was released for Ubuntu 16.04.
You need to log in before you can comment on or make changes to this bug.