Regression forward button in location bar performs distracting animation sometimes when switching to pending tabs

REOPENED
Unassigned

Status

()

Firefox
Theme
--
minor
REOPENED
a year ago
11 months ago

People

(Reporter: 684sigma, Unassigned)

Tracking

({regressionwindow-wanted, reproducible, ux-minimalism})

52 Branch
regressionwindow-wanted, reproducible, ux-minimalism
Points:
---

Firefox Tracking Flags

(firefox-esr45 unaffected, firefox52 wontfix, firefox-esr52 affected)

Details

(Reporter)

Description

a year ago
I have a problem with Firefox Beta 52. It doesn't happen in Firefox ESR 45.
Sometimes when I switch to tab, forward button in location bar performs distracting animation.
It happens unpredictably, however, I noticed one specific scenario when it happens

1. Open new window, open 5 tabs in that window. In each tab open http://www.bbc.com/news , then navigate to homepage and back
2. Open new tab, then close and restore the window
3. Switch to first tab. Switch to second tab. Switch to third tab and so on

Result: forward button in each tab flashes and performs distracting animation. When I switch to tab, forward button is initially displayed, but after a moment it disappears and appears with animation from behind of back button.
Expected: no animation and flashing. ESR 45 works fine

Forward button and back button are located in location bar.

Updated

a year ago
Severity: normal → minor
Has STR: --- → yes
status-firefox52: --- → affected
status-firefox-esr45: --- → unaffected
status-firefox-esr52: --- → affected
Component: Untriaged → Theme
Keywords: reproducible, ux-minimalism
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1338881
(Reporter)

Comment 2

a year ago
In Bug 1338881 user actions were described as:
> When switching from a tab that shows the forward button to a tab with the forward button hidden, or vice versa, the forward button should hide / show immediately without the animation.
This bug happens when switching from one tab with forward button shown to another tab with forward button shown.
Therefore it's not a duplicate.

Bug 1338881 result was described as:
> the forward button should hide / show immediately without the animation. This doesn't seem to work all the time.
implying that forward button changes visibility once, with animation, and animation is the bug.
This bug is that forward button changes visibility twice (regardless from animation): "forward button is initially displayed, but after a moment it disappears and appears...". Distracting animation is just a bonus.
Therefore it's not a duplicate.

Also, this bug includes a 100% way to reproduce this, while bug 1338881 only says that "This doesn't seem to work all the time". If you're sure that they are duplicates, please mark bug 1338881 as duplicate of this one, instead of just copy-pasting scenario from comment 0 to bug 1338881; doing otherwise devalues the time reporter spent.
It was not easy to track down exact case when the bug happens.
Flags: needinfo?(dao+bmo)
Summary: Regression forward button in location bar performs distracting animation sometimes → Regression forward button in location bar performs distracting animation sometimes when switching to pending tabs
Status: RESOLVED → REOPENED
Depends on: 1338881
Ever confirmed: true
Flags: needinfo?(dao+bmo)
Keywords: regressionwindow-wanted
Resolution: DUPLICATE → ---

Comment 3

a year ago
I expect this is related to e10s and session restore, which is changing the canGoForward/canGoBack state of the docshell when closing and restoring a window (which is step 2 in the STR), rather than an issue with the actual theme (though the theme might be able to work around it).
Mass wontfix for bugs affecting firefox 52.
status-firefox52: affected → wontfix
You need to log in before you can comment on or make changes to this bug.