Fullscreen doesn't show toolbars when I uncheck hide toolbars

UNCONFIRMED
Unassigned

Status

()

Firefox
Toolbars and Customization
UNCONFIRMED
a year ago
a year ago

People

(Reporter: 684sigma, Unassigned, NeedInfo)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
I have a problem with Firefox Beta 52.
Sometimes I mistakenly enable "Hide toolbars" option in fullscreen and want to disable it. When I disable it, toolbars don't show up.
It happens unpredictably, however, I noticed one specific scenario when it happens

1. Switch to fullscreen mode. Disable "Hide toolbars" option, browse for a while
2. Enable "Hide toolbars" option.
3. While animation of toolbars is still going on, right-click any button, disable "Hide toolbars"

Result: animation continues, then toolbars hide completely
Expected: I disabled "Hide toolbars", so toolbars should be visible

Comment 1

a year ago
I can't reproduce the problem in Fx52.0 on Win10, maybe missing the "browse for a while" or else.
Component: Untriaged → Toolbars and Customization
(Reporter)

Comment 2

a year ago
(In reply to YF (Yang) from comment #1)
> I can't reproduce the problem in Fx52.0 on Win10, maybe missing the "browse
> for a while" or else.

No, "browse for a while" was only added to describe what I was doing. This is not necessary to reproduce.
To reliably reproduce the bug, it's necessary to wait until animation of toolbars finishes, after right-clicking any button in toolbar, but before disabling the option. I'll add a video soon.
Flags: needinfo?(684sigma)
You need to log in before you can comment on or make changes to this bug.