Closed Bug 1345491 Opened 5 years ago Closed 5 years ago

Intermittent toolkit/components/extensions/test/mochitest/test_ext_proxy.html | message queue is empty - got "[\"proxy-error-received\"]", expected "[]"

Categories

(WebExtensions :: General, defect)

defect
Not set
normal

Tracking

(firefox55 fixed)

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: mattw)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed])

Attachments

(1 file)

Flags: needinfo?(mwein)
New test added in bug 1295807.
Blocks: 1295807
Assignee: nobody → mwein
Flags: needinfo?(mwein)
:mattw, thanks for looking into this- as this is a new test, please make this stable.  If you need help interpretting logs or running on try, ask for help, that is something myself or gbrown can help with.
Whiteboard: [stockwell needswork]
(In reply to Joel Maher ( :jmaher) from comment #5)
> :mattw, thanks for looking into this- as this is a new test, please make
> this stable.  If you need help interpretting logs or running on try, ask for
> help, that is something myself or gbrown can help with.

Thanks Joel, I just saw this. I will reach out to you or gbrown this week to try to get help resolving this.
I believe the issue is that the test closes the window before the extension is unloaded.
Comment on attachment 8856346 [details]
Bug 1345491 - Fix intermittent caused by closing window before extension is unloaded

https://reviewboard.mozilla.org/r/128258/#review130902
Comment on attachment 8856346 [details]
Bug 1345491 - Fix intermittent caused by closing window before extension is unloaded

https://reviewboard.mozilla.org/r/128260/#review130904
Attachment #8856346 - Flags: review?(gbrown) → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/23546115feb2
Fix intermittent caused by closing window before extension is unloaded r=gbrown
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/23546115feb2
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Depends on: 1356457
I still see failures for this test, but I do see more failures and it looks like we created a new bug to track failures:
https://bugzilla.mozilla.org/show_bug.cgi?id=1356457

you can see 13 failures for that bug in the last day:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1356457&startday=2017-04-08&endday=2017-04-15&tree=all


the newer failures are primarily on linux32 debug, should we leave this bug as closed and work on bug 1356457 instead?
I don't see any failures after April 14th, possibly this is fixed now.
Whiteboard: [stockwell needswork] → [stockwell fixed]
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.