Closed Bug 134555 Opened 19 years ago Closed 19 years ago

xul "description" element "value=" text is not selectable

Categories

(Core :: DOM: Selection, defect)

x86
Linux
defect
Not set
minor

Tracking

()

RESOLVED WONTFIX

People

(Reporter: neal, Assigned: mjudge)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020313
BuildID:    2002031312

The "description" element in XUL, when used with the
"value=" attribute, produces text that cannot be selected.

E.g.

<description value="This text cannot be selected with the mouse"/>

but this works fine:

<description>
But this this text can be selected.
</description>

I would think that both should be selectable.  [I wish more text
in mozilla was - e.g. error messages in dialog boxes].

If this is the intended behavior, it should be documented,
along with some other way to use xul templates and rdf data sources to display
text that the user can cut and paste.



Reproducible: Always
Steps to Reproduce:
1.visit  http://bcn.boulder.co.us/~neal/tmp/xulexample.xul
and try to select the top line of text.


Actual Results:  couldn't select top line, but could select bottom line.

Expected Results:  Want to be able to cut and paste both lines.
AndrewW told me on irc that this is probably a bug.
confirming (linux trunk 2002033119)
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
the first cannot be described in the DOM the second can. thats why i am sure 
selection wont pick it up since selection is a collection of DOMRanges..
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.