Closed Bug 1345552 Opened 3 years ago Closed 3 years ago

Disable Windows a11y+e10s in 54

Categories

(Core :: Disability Access APIs, defect)

54 Branch
Unspecified
Windows
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
firefox54 + fixed

People

(Reporter: aklotz, Assigned: aklotz)

References

Details

(Whiteboard: aes+)

Attachments

(3 files)

+++ This bug was initially created as a clone of Bug #1333250 +++

+++ This bug was initially created as a clone of Bug #1325690 +++

Let's disable a11y+e10s by default in Aurora 54.
Version: 52 Branch → 54 Branch
Whiteboard: aes+
(These are the same patches as bug 1333250, but rebased to 54 Aurora)
Comment on attachment 8845079 [details] [diff] [review]
Part 1: Restore a11y+e10s checks

Approval Request Comment
[Feature/Bug causing the regression]: Windows a11y on e10s
[User impact if declined]: Instability; new target version for this feature is 55
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: No - it is a direct uplift to Aurora
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: All patches in this bug
[Is the change risky?]: No
[Why is the change risky/not risky?]: This change has already been made in 52 and 53.
[String changes made/needed]: None
Attachment #8845079 - Flags: approval-mozilla-aurora?
Comment on attachment 8845079 [details] [diff] [review]
Part 1: Restore a11y+e10s checks

no e10s with a11y in aurora54.

Thanks Aaron.
Attachment #8845079 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
And a follow-up to re-disable the e10s a11y browser-chrome tests since they were permafailing (unsurprisingly, I guess).
https://hg.mozilla.org/releases/mozilla-aurora/rev/be7a2a07bda7

Yura, aklotz wanted me to check with you to confirm that there was no other follow-up needed with respect to tests here.
Flags: needinfo?(yzenevich)
Only 1 test seems to be failing which feels like a regression. These tests seem to be passing on nightly, which is not much different from aurora that was branched this week. I will try to run these locally to see if I can get to the root cause.
Confirming that this was fine.
Flags: needinfo?(yzenevich)
You need to log in before you can comment on or make changes to this bug.