Clicking on down arrow in Bookmarks in Sidebar opens new window

VERIFIED DUPLICATE of bug 9029

Status

SeaMonkey
Sidebar
P3
normal
VERIFIED DUPLICATE of bug 9029
19 years ago
13 years ago

People

(Reporter: cpratt, Assigned: David Hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build ID: 1999090908
Platform: RH Linux 6, Windows NT

To reproduce:
- Launch apprunner
- Display the sidebar
- Scroll down to see the Bookmarks area
- Click a few times on the down arrow on the scrollbar in the Bookmarks area

Result: A new browser window is opened. In this window, the following files are
listed: bm-panel.xul, bm-props.js, bm-props.xul, bookmark-popup.js... etc.

Expected result: Nothing should happen if the list has already been scrolled all
the way down.

Updated

18 years ago
Assignee: slamm → hyatt

Comment 1

18 years ago
I see this too. Looks like a tree bug.
Reassigning to hyatt.

Comment 2

18 years ago
*** Bug 13379 has been marked as a duplicate of this bug. ***

Comment 3

18 years ago
*** Bug 13646 has been marked as a duplicate of this bug. ***

Comment 4

18 years ago
*** Bug 11508 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

18 years ago
My hands have deteriorated to the point where I can no longer type.  I need
help.  If you think you can fix this bug on your own, please take it away from
me.  If you'd like to volunteer to be my hands for a specific bug, then I'll be
happy to come up to your cube and sit with you and fix the bug (assuming you
have the patience for that).
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 6

18 years ago
*** This bug has been marked as a duplicate of 9029 ***
(Reporter)

Comment 7

18 years ago
Not being terrifically bright when it comes to DOM, how exactly is this a
duplicate of "DOM events with anonymous nodes as targets should not bubble up to
non-anonymous nodes"? Please help!
(Assignee)

Comment 8

18 years ago
The scrollbar click should be consumed before the handler that is installed on
the tree even sees it.  Because it is being allowed to bubble up from the
scrollbar to the tree, the handler on the tree mistakenly views the click on the
scrollbar as a click on a bookmark item in the tree.

The fix is to prevent the click event on the scrollbar from being seen by the
handler on the tree.
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 9

18 years ago
Aha! Verifying this one as duplicate.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.