Inputting wrong Touch ID twice hides the keyboard for passcode

RESOLVED WONTFIX

Status

()

Firefox for iOS
Login Management
P3
normal
RESOLVED WONTFIX
9 months ago
4 months ago

People

(Reporter: Adrian Oniga, Unassigned)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios9.0, fxios-v7.0 affected, fxios-v8.0 affected)

Details

(Whiteboard: [MobileCore][papercut])

Attachments

(1 attachment)

(Reporter)

Description

9 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

1.Open Firefox
2.Go to Settings-Touch ID & Passcode
3.Set a Passcode  and enable "Use Touch ID"
4.Go to Settings-"Logins" and use the wrong Touch ID (fingerprint) twice 


Actual results:

4.Inputting wrong Touch ID twice hides the keyboard for passcode


Expected results:

2.Touch ID & Passcode menu is displayed
3.Passcode is set and "Use Touch ID" is enabled 
4.Inputting wrong Touch ID twice or more should not hide the keyboard
(Reporter)

Comment 1

9 months ago
Found on iPhone 6, iOS 10.2.1, Firefox version 8.0(1), buddybuild #1959
(Reporter)

Comment 2

9 months ago
Steps 2 and 3 from Expected are at the Actual results

Comment 3

9 months ago
Issue is reproducible also on 7.0b1986 and on latest buddy build #1993.
Blocks: 1198418
Status: UNCONFIRMED → NEW
status-fxios-v7.0: --- → affected
status-fxios-v8.0: --- → affected
tracking-fxios: --- → ?
Ever confirmed: true

Updated

8 months ago
tracking-fxios: ? → 8.0+

Updated

8 months ago
Flags: needinfo?(catalin.suciu)
When reopening the passcode dialog, the keyboard will be correctly displayed.
Flags: needinfo?(catalin.suciu)

Updated

8 months ago
Priority: -- → P3
Whiteboard: [MobileCore]

Updated

6 months ago
tracking-fxios: 8.0+ → 9.0

Updated

5 months ago
Component: General → Login Management
Whiteboard: [MobileCore] → [MobileCore][papercut]

Comment 5

4 months ago
Created attachment 8886689 [details]
Screenshot 2017-07-14 16.34.33.png

Comment 6

4 months ago
(In reply to Adrian Oniga from comment #0)
>
> 4.Inputting wrong Touch ID twice hides the keyboard for passcode
> 

I see a modal with no keyboard at this step: see Screenshot 2017-07-14 16.34.33.png attached to this bug.

Then, after 3 failed attempts the modal hides, this seems ok. I think I am not understanding the repro steps for this bug.

Comment 7

4 months ago
Re-tested with latest master deb9736c9. This issue is no longer reproducible on iOS 10.3 but I still manage to reproduce this issue in the simulator with iOS 10.2.
This seems WONTFIX to me.

Comment 9

4 months ago
Yup to wontfix, seems to have been improved since bug was filed
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.