Crash when clicking abort in file picker dialogue

RESOLVED DUPLICATE of bug 1322608

Status

()

Core
Widget: Gtk
--
critical
RESOLVED DUPLICATE of bug 1322608
9 months ago
8 months ago

People

(Reporter: Linus Kardell, Unassigned)

Tracking

({crash})

51 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170126000000

Steps to reproduce:

1. Click button on a webpage do select a file, thus opening the file picker
2. Click abort in the file picker


Actual results:

Browser crashes


Expected results:

File picker closes
(Reporter)

Updated

9 months ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

9 months ago
This is on OpenSUSE Leap 42.2 using KDE Plasma. I think it uses the Qt4 file picker.

Comment 2

9 months ago
https://developer.mozilla.org/en-US/docs/How_to_get_a_stacktrace_for_a_bug_report
Severity: normal → critical
Component: Untriaged → Widget: Gtk
Keywords: crash
Product: Firefox → Core
(In reply to Linus Kardell from comment #1)
> I think it uses the Qt4 file picker.

Also, please try with a different GTK theme, but the stack track will provide more info.
(Reporter)

Comment 4

8 months ago
bp-c8bbeabd-607c-4636-8db4-f50942170312
bp-01a3ceb3-d43b-4cc4-b307-97ac52170312
bp-9a8a09cb-7104-4eb0-a084-444072170312

I tried changing GTK and Qt themes, but that didn't change the result.
Those reports have a funny build id of 20170126000000, and crash-stats doesn't recognize it.
51.0.1 should have 20170125094131.
Is the build from http://www.mozilla.com/en-US/firefox/ ?
(Reporter)

Comment 6

8 months ago
No, this is the build from the OpenSUSE Repos. The official build (build id 20170125094131) uses the GTK file picker, and does not experience this issue.

Found other bug reports here:
https://bugzilla.opensuse.org/show_bug.cgi?id=1015998
https://bugzilla.mozilla.org/show_bug.cgi?id=1322608
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1322608
You need to log in before you can comment on or make changes to this bug.