The newegg favicon blinks incessantly in nightly

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
2 years ago
a month ago

People

(Reporter: canuckistani, Assigned: bkelly)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox55 affected)

Details

STR:

1. load a newegg.ca product page, eg https://www.newegg.com/Product/Product.aspx?Item=N82E16833704133&nm_mc=AFC-C8Junction&cm_mmc=AFC-C8Junction-tonymacx86%20LLC-_-na-_-na-_-na&cm_sp=&AID=10446076&PID=4902415&SID=

2. notice that the favicon blinks incessantly. 

Are they doing something wrong? Is it us? It's pretty distracting.

cc'ing Michael Taylor in case this is just webcompat.
Wowzers, this reproduces in Dev Edition 53 as well, and seems to be thrashing my CPU.

Note: I see the same behavior in Firefox when spoofing as Chrome.

Updated

2 years ago
Component: General → Untriaged
This issue is reproducible also on Firefox latest release v52. I did a regression range and here is the result:

Narrowed inbound regression window from [d19cffea, 8c2ad636] (3 revisions) to [d19cffea, 24d97dc5] (2 revisions) (~1 steps left)
Oh noes, no (more) inbound revisions :(
Last good revision: d19cffeae1febc6d669a024340de25228e544475
First bad revision: 24d97dc514d4b8fe608e9aee7527615c1e613606
INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d19cffeae1febc6d669a024340de25228e544475&tochange=24d97dc514d4b8fe608e9aee7527615c1e613606

Looks like the following bug has the changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1300659

@Ben, can you take a look at this ?
Blocks: 1300659
Component: Untriaged → DOM
Flags: needinfo?(bkelly)
Product: Firefox → Core
I can't reproduce this on my machine.  What platform are you guys seeing it on?
Flags: needinfo?(bkelly) → needinfo?(jgriffiths)
(In reply to Ben Kelly [not reviewing due to deadline][:bkelly] from comment #3)
> I can't reproduce this on my machine.  What platform are you guys seeing it
> on?

macOS 10.12.4 Beta (16E183b)
Flags: needinfo?(jgriffiths)
(In reply to Ben Kelly [not reviewing due to deadline][:bkelly] from comment #3)
> I can't reproduce this on my machine.  What platform are you guys seeing it
> on?

I am using Windows 8.1 x64 with latest Nightly build, latest Firefox release also on 64-bit.
Can you clarify:  Does this continue to blink for you or does it blink a few times and then stabilize?
Flags: needinfo?(jgriffiths)
(Assignee)

Updated

2 years ago
Assignee: nobody → bkelly
Status: NEW → ASSIGNED
(In reply to Ben Kelly [not reviewing due to deadline][:bkelly] from comment #6)
> Can you clarify:  Does this continue to blink for you or does it blink a few
> times and then stabilize?

It just keeps going, and I get 100% cpu on one core.
Flags: needinfo?(jgriffiths)
Sorry for the continued questions, but I can't reproduce on my windows desktop or my mac laptop yet.  I tried in private browsing as well in case its related to tracking scripts somehow.

Can you post about:support output here?  Can you try in a fresh profile?
Flags: needinfo?(jgriffiths)
A mac os process monitor "sample process" of the process using 100% cpu might help as well.  Likely it doesn't have symbols, though.
(In reply to Ben Kelly [not reviewing due to deadline][:bkelly] from comment #8)
> Sorry for the continued questions, but I can't reproduce on my windows
> desktop or my mac laptop yet.  I tried in private browsing as well in case
> its related to tracking scripts somehow.
> 
> Can you post about:support output here?  Can you try in a fresh profile?

I spent some more ( probably too much ) time on this:

1. I can't repro with a fresh profile with nightly or release
2. I tried disabling all extensions but could still repro, but then after a restart of nightly on the affected profile caused me to no longer be able to repro

¯\_(ツ)_/¯

I suspected wen I logged this bug it was probably a problem on newegg's site, and it's possible they fixed it on their end.
Flags: needinfo?(jgriffiths)
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Component: DOM → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.