Update to Thunderbird 45.8 removes Lightning

RESOLVED WORKSFORME

Status

Calendar
General
RESOLVED WORKSFORME
11 months ago
9 months ago

People

(Reporter: Bruce A. Johnson, Unassigned)

Tracking

Lightning 4.7.8

Details

(Reporter)

Description

11 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

Let Thunderbird automatically update to version 45.8


Actual results:

When Thunderbird restarted after the update, Lightning (calendar) add-on was no longer installed.


Expected results:

Keep Lightning.

This happened with me with Windows 10.  I just fielded a support question where it happened to someone else (unknown OS).

Comment 1

11 months ago
Yep, it happens every once in a while, cause unknown, see for example bug 1258474, bug 1326554, bug 1326474, bug 1329468 and others.

The standard answer is in bug 1329468 comment #4. If you read through that bug, the user lost his entire profile. So preferably don't do that ;-)

After removing the {e2fda1a4-762b-4020-b5ad-a41df1933103} folder, Lightning should spring back to life, if it doesn't, get it from AMO.
Component: Untriaged → General
Product: Thunderbird → Calendar
Version: 45 Branch → Lightning 4.7.8

Comment 2

11 months ago
(In reply to Bruce A. Johnson from comment #0)

Happened to me too. Windows 7 x64. Went to addons and reinstalled Lightning and everything came back.

Easy solution (hope it is the safest!), but shouldn't have happened in the first place.
Reinstalling Lightning should be safe, as the profile is separate. I'm closing this WFM as we have a few other bugs open on this matter. It is unfortunately hard to pinpoint the cause of this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.