Closed Bug 1345702 Opened 3 years ago Closed 2 years ago

remove support for <style scoped>

Categories

(Core :: CSS Parsing and Computation, enhancement, P3)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1444905

People

(Reporter: bholley, Unassigned)

References

Details

We will need some machinery to support XBL scoped stylesheets to make video controls work. That work is tracked in bug 1290276.

Once we have that, we also need to consider <style scoped>. There's discussion about removing it in bug 1291515, with people leaning to keep it. If we keep it, we'll need to implement it, which hopefully won't be too much work after bug 1290276 is done.
Over to Ting-Yu to work on alongside bug 1290276.
Assignee: nobody → tlin
Priority: P3 → P1
See Also: → 1291515
Since we decided to remove support for <style scoped>, morphing this bug into the removal.  Bug 1291515 is for disabling it in content documents, so this one blocks stylo being used in chrome documents.
Assignee: tlin → nobody
Blocks: stylo-chrome
No longer blocks: stylo
Priority: P1 → --
Summary: stylo: Implement (or remove) <style scoped> → remove support for <style scoped>
Depends on: 1374555
Remove bug 1290276 from the block list because it doesn't affect removing <style scoped>.
No longer blocks: stylo-chrome
Blocks: stylo-chrome
No longer depends on: 1290276
Depends on: 1204818
Priority: -- → P3
There is no chrome document except about:reader using <style scoped> right now, and about:reader shouldn't block us from using stylo elsewhere. Move it to block stylo-everywhere instead.
Blocks: stylo-everywhere
No longer blocks: stylo-chrome, stylo-svg
Depends on: 1417837
No longer depends on: 1204818
No longer blocks: stylo-everywhere
Status: NEW → RESOLVED
Closed: 2 years ago
No longer depends on: 1374555, 1375224, 1417837
Resolution: --- → DUPLICATE
Duplicate of bug: 1444905
You need to log in before you can comment on or make changes to this bug.