Intermittent dom/tests/browser/browser_largeAllocation_non_win32.js | This test exceeded the timeout threshold. It should be rewritten or split up. If that's not possible, use requestLongerTimeout(N), but only as a last resort. -

RESOLVED FIXED in Firefox 58

Status

()

P2
normal
RESOLVED FIXED
2 years ago
9 months ago

People

(Reporter: intermittent-bug-filer, Assigned: Nika)

Tracking

({intermittent-failure})

unspecified
mozilla58
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox58 fixed)

Details

(Whiteboard: [stockwell unknown])

Attachments

(1 attachment)

1 failures in 718 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 1

Platform breakdown:
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1345733&startday=2017-06-26&endday=2017-07-02&tree=all
2 failures in 656 pushes (0.003 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 1
* autoland: 1

Platform breakdown:
* linux64: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1345733&startday=2017-07-03&endday=2017-07-09&tree=all
Priority: -- → P5
5 failures in 720 pushes (0.007 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 4
* mozilla-central: 1

Platform breakdown:
* linux64: 4
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1345733&startday=2017-07-10&endday=2017-07-16&tree=all
2 failures in 822 pushes (0.002 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 1
* autoland: 1

Platform breakdown:
* linux64: 1
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1345733&startday=2017-07-17&endday=2017-07-23&tree=all
4 failures in 1008 pushes (0.004 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 3
* try: 1

Platform breakdown:
* linux64: 2
* linux32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1345733&startday=2017-07-24&endday=2017-07-30&tree=all
2 failures in 888 pushes (0.002 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 1
* autoland: 1

Platform breakdown:
* windows8-64: 1
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1345733&startday=2017-07-31&endday=2017-08-06&tree=all
3 failures in 908 pushes (0.003 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 2
* mozilla-inbound: 1

Platform breakdown:
* linux32: 2
* linux32-stylo: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1345733&startday=2017-08-21&endday=2017-08-27&tree=all
14 failures in 939 pushes (0.015 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 10
* try: 2
* mozilla-inbound: 1
* mozilla-central: 1

Platform breakdown:
* linux32-stylo: 11
* linux32: 2
* linux64-stylo: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1345733&startday=2017-08-28&endday=2017-09-03&tree=all
12 failures in 924 pushes (0.013 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 6
* mozilla-inbound: 3
* try: 2
* mozilla-central: 1

Platform breakdown:
* linux32-stylo: 5
* linux32: 4
* linux64: 2
* linux64-stylo: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1345733&startday=2017-09-04&endday=2017-09-10&tree=all
33 failures in 1032 pushes (0.032 failures/push) were associated with this bug in the last 7 days.   

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. **  

Repository breakdown:
* autoland: 12
* mozilla-inbound: 10
* mozilla-central: 5
* try: 4
* mozilla-beta: 2

Platform breakdown:
* linux32: 28
* linux32-stylo-disabled: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1345733&startday=2017-09-11&endday=2017-09-17&tree=all
Priority: P5 → --
Whiteboard: [stockwell needswork:owner]
The intermittent failure rate rose up. Would you be able to take a look, Michael?
Flags: needinfo?(michael)
(Assignee)

Comment 12

a year ago
From the occurrences appearing in the orangefactor link, it looks like this timeout is only occurring on 32-bit linux builds. In addition, it appears as though the problem is just that process creation, especially spamming it like is done in this test, is really slow. In the test which is timing out we create at least 14 new content processes.

I'm inclined to request a longer timeout (Currently it's only requestLongerTimeout(2), so I could probably bump it up to 4), or disable the expensive large allocation force-enable tests on linux32 (as we never actually respect the Large-Allocation header in 32-bit builds. The disadvantage of disabling here would be that if we decide in the future we want to respect the header on all 32-bit platforms, we won't have testing.
Flags: needinfo?(michael)
1 failures in 943 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* autoland: 1

Platform breakdown:
* linux32-stylo-disabled: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1345733&startday=2017-09-18&endday=2017-09-24&tree=all
Whiteboard: [stockwell needswork:owner] → [stockwell unknown]
Trying a longer timeout first sounds good.
Priority: -- → P2
(Assignee)

Updated

a year ago
Assignee: nobody → michael
(Assignee)

Comment 15

a year ago
Created attachment 8912004 [details] [diff] [review]
Increase timeout for large allocation tests

Oops, forgot to attach this.
Attachment #8912004 - Flags: review?(bugs)

Updated

a year ago
Attachment #8912004 - Flags: review?(bugs) → review+

Comment 16

a year ago
Pushed by michael@thelayzells.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/827357e7c274
Increase timeout for large allocation tests, r=smaug

Comment 17

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/827357e7c274
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox58: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
1 failures in 147 pushes (0.007 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-release: 1

Platform breakdown:
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1345733&startday=2017-12-25&endday=2017-12-31&tree=all
1 failures in 462 pushes (0.002 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-release: 1

Platform breakdown:
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1345733&startday=2018-01-01&endday=2018-01-07&tree=all
1 failures in 788 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-release: 1

Platform breakdown:
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1345733&startday=2018-01-08&endday=2018-01-14&tree=all
You need to log in before you can comment on or make changes to this bug.