Closed Bug 1345749 Opened 3 years ago Closed 3 years ago

Video is not clipped correctly during scrolling out on Youtube

Categories

(Core :: Graphics: WebRender, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55

People

(Reporter: sotaro, Assigned: sotaro)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

No description provided.
Assignee: nobody → sotaro.ikeda.g
Blocks: webrender
During Youtube video playback, if upper half of video is scrolled out, bottom part of video should be rendered. But in current graphics branch, upper half of video was rendered in the situation.
Attached patch patch - Apply RelativeToVisible (obsolete) — Splinter Review
Attachment #8845272 - Attachment is obsolete: true
In attachment 8845308 [details] [diff] [review], reftest change for object-fit-none-webm-001.html and object-fit-none-webm-002.html is a bit tricky. With attachment 8845308 [details] [diff] [review], tests became passed only when webrender is enabled and non-e10s. It is assumed that with webrender, YUV to RGB conversion is done by software on Graphic branch. It seems to cause the unexpected tests passes.
Attachment #8845308 - Flags: review?(jmuizelaar)
Attachment #8845308 - Flags: review?(jmuizelaar) → review+
Pushed by sikeda@mozilla.com:
https://hg.mozilla.org/projects/graphics/rev/d00975e8c2d1
Apply RelativeToVisible r=jrmuizel
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
There was another rebasing mistake...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Sotaro Ikeda [:sotaro] from comment #8)
> There was another rebasing mistake...

Sorry, the mistake was in Bug 1345712.
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.