Closed Bug 1345754 Opened 3 years ago Closed 3 years ago

Only validate when there are no pending changes

Categories

(Firefox :: Sync, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 55
Tracking Status
firefox53 --- unaffected
firefox54 --- fixed
firefox55 --- fixed

People

(Reporter: markh, Assigned: tcsc)

Details

Attachments

(1 file)

This was supposed to land as part of bug 1317223, but I think I screwed up by failing to apply https://bug1317223.bmoattachments.org/attachment.cgi?id=8837819 before landing. We should take that patch and land it - it's got r+. We should also uplift it.
Priority: -- → P1
Assignee: nobody → tchiovoloni
It's not identical since it seems like... half of that patch made it in? Not sure what the deal with that is...
Comment on attachment 8847218 [details]
Bug 1345754 - Skip sync bookmark repair and validation if we have pending changes

https://reviewboard.mozilla.org/r/120226/#review124210

Looks great, thanks. Can you please get a bug on file for optimizing the new PlacesSyncUtils method using LIMIT 1 or something else - I'm worried about people with massive amounts of bookmarks that are failing to sync due to (say) too many records in a single folder will notice the cost.
Attachment #8847218 - Flags: review?(markh) → review+
Pushed by tchiovoloni@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/85561efb5a00
Skip sync bookmark repair and validation if we have pending changes r=markh
https://hg.mozilla.org/mozilla-central/rev/85561efb5a00
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Comment on attachment 8847218 [details]
Bug 1345754 - Skip sync bookmark repair and validation if we have pending changes

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1317223
[User impact if declined]: Bookmark repair will be attempted unnecessarily in some cases.
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Manually
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: N/A
[Is the change risky?]: Low risk
[Why is the change risky/not risky?]: Limited to sync, changes only occur during bookmark repair, which is already fairly unlikely (and this patch makes it less likely).
[String changes made/needed]: N/A
Attachment #8847218 - Flags: approval-mozilla-aurora?
Comment on attachment 8847218 [details]
Bug 1345754 - Skip sync bookmark repair and validation if we have pending changes

Fix a bookmark repair issue. Aurora54+.
Attachment #8847218 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.