Status

defect
P3
normal
VERIFIED FIXED
20 years ago
15 years ago

People

(Reporter: skasinathan, Assigned: scottputterman)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Overview Description: Folders shows up twice upon opening it. Something like
this.

Drafts
Templates
....
Drafts
Templates
.....

Steps to Reproduce:
1. Start messenger using Task | Messenger.
2. Click on twisty to view the folders.
3. All the folders shows up twice.

Build Date & Platform Bug Found:
1999-09-09-09-M10, Windows Release build.

Additional Builds and Platforms Tested On:
1999-09-09-08-M11, Linux build. (Esther tested this).
Assignee: phil → putterman
re-assigning to putterman.

adding mscott, alecf and bienvenu to the cc list so they can add suggestions.

alecf, you had a guess at what it might be?  something with existance detection
code with RDF assertion?
I think this too is because of the duplicate detection code that was removed
yesterday....:(
Hmm.  I have to look into that, but if it is then it's because we're doing
something wrong elsewhere.
This is happening because I exposed what I think is a bug in
nsMsgAccountManagerDS.cpp.  It returns that it knows kNC_Child regardless of
what the source is.  Therefore, RDF asks for the child property twice.  I can
fix this by only adding that arc if it knows how to answer it for the source.

Chris, I cc'd you on this, because I guess one could argue that 2 different
datasources would know how to answer GetTargets for a given source and property.
That means that for the arcsout enumerator, keeping track of those dups is
probably a good idea.  Unfortunately, if I add it back in, there's a big
performance loss.
Why don't you back out your change for now, and we can figure out how to make
the front end not be so stupid.
Let me say that again. Why don't we _temporarily_ back out your change to the
composite data source, then we'll fix the front end, then we'll put your change
back in.
I have a fix for our datasources to make this work out.  The question is, do we
need the duplication code for other places?  Are there other composite
datasources that are depending on this? And, if we have to put it back in, could
we put it in as something other than an array with n^2 lookup?  I would prefer
not to lose the perf gain if possible.
Ok, let's fix the datasource then. I can deal with any other places where this
turns up as a problem.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
I just checked in the fix for this.
putterman, I tried to update your changes in my tree. When I did nmake, I get
the following error.

Microsoft (R) Program Maintenance Utility   Version 6.00.8168.0
Copyright (C) Microsoft Corp 1988-1998. All rights reserved.

+++ make: exporting headers
nsMsgAccountManagerDS.cpp
D:\mozilla\mailnews\base\src\nsMsgAccountManagerDS.cpp(267) : error C2661: 'crea
teNode' : no overloaded function takes 3 parameters
NMAKE : fatal error U1077: 'cl' : return code '0x2'
Stop.
NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio\VC98\bin\N
MAKE.EXE"' : return code '0x2'
Stop.
Suresh,

Are you updated in the rest of the directory? I don't think I checked anything
in that would affect that line.
No. I just updated the directory you checked in.
I will update my entire tree.
just that directory should have been sufficient.
Status: RESOLVED → VERIFIED
linux (1999-09-13-08 m11)
Win_nt 4.0 (1999-09-10-10 M11)
Mac (1999-09-10-09 M11)
Folders do not show up twice any more.
Changing: (OS) Windows 3.1 -> All, per comment 0.
(This will help on bug 165825 :-))
OS: Windows 3.1 → All
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.