Crash in std::sys::imp::thread_local::create

RESOLVED DUPLICATE of bug 1320134

Status

()

--
critical
RESOLVED DUPLICATE of bug 1320134
2 years ago
a year ago

People

(Reporter: philipp, Unassigned)

Tracking

({crash, regression})

53 Branch
x86
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(firefox52 unaffected, firefox53- fix-optional)

Details

(Whiteboard: [ps-radar], crash signature)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-5befa8fd-7b2a-4f55-856b-40c312170309.
=============================================================
Crashing Thread (36)
Frame 	Module 	Signature 	Source
0 	xul.dll 	std::panicking::rust_panic_with_hook 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:426
1 	xul.dll 	std::panicking::begin_panic<&str> 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:413
2 	xul.dll 	std::sys::imp::thread_local::create 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys/windows/thread_local.rs:69
3 	xul.dll 	std::sys_common::thread_local::StaticKey::lazy_init 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys_common/thread_local.rs:180
4 	xul.dll 	std::panicking::update_panic_count::PANIC_COUNT::__getit 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/thread/local.rs:163
5 	xul.dll 	std::panicking::rust_panic_with_hook 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:426
6 	xul.dll 	std::panicking::begin_panic<&str> 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:413
7 	xul.dll 	std::sys::imp::thread_local::create 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys/windows/thread_local.rs:69
8 	xul.dll 	std::sys_common::thread_local::StaticKey::lazy_init 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys_common/thread_local.rs:180
9 	xul.dll 	std::panicking::update_panic_count::PANIC_COUNT::__getit 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/thread/local.rs:163
10 	xul.dll 	std::panicking::rust_panic_with_hook 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:426
11 	xul.dll 	std::panicking::begin_panic<&str> 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:413
12 	xul.dll 	std::sys::imp::thread_local::create 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys/windows/thread_local.rs:69
13 	xul.dll 	std::sys_common::thread_local::StaticKey::lazy_init 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys_common/thread_local.rs:180
14 	xul.dll 	std::panicking::update_panic_count::PANIC_COUNT::__getit 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/thread/local.rs:163
15 	xul.dll 	std::panicking::rust_panic_with_hook 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:426
16 	xul.dll 	std::panicking::begin_panic<&str> 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:413
17 	xul.dll 	std::sys::imp::thread_local::create 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys/windows/thread_local.rs:69
18 	xul.dll 	std::sys_common::thread_local::StaticKey::lazy_init 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys_common/thread_local.rs:180
19 	xul.dll 	std::panicking::update_panic_count::PANIC_COUNT::__getit 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/thread/local.rs:163
20 	xul.dll 	std::panicking::rust_panic_with_hook 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:426
21 	xul.dll 	std::panicking::begin_panic<&str> 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:413
22 	xul.dll 	std::sys::imp::thread_local::create 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys/windows/thread_local.rs:69
23 	xul.dll 	std::sys_common::thread_local::StaticKey::lazy_init 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys_common/thread_local.rs:180
24 	xul.dll 	std::panicking::update_panic_count::PANIC_COUNT::__getit 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/thread/local.rs:163
25 	xul.dll 	std::panicking::rust_panic_with_hook 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:426
26 	xul.dll 	std::panicking::begin_panic<&str> 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:413
27 	xul.dll 	std::sys::imp::thread_local::create 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys/windows/thread_local.rs:69
28 	xul.dll 	std::sys_common::thread_local::StaticKey::lazy_init 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys_common/thread_local.rs:180
29 	xul.dll 	std::panicking::update_panic_count::PANIC_COUNT::__getit 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/thread/local.rs:163
30 	xul.dll 	std::panicking::rust_panic_with_hook 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:426
31 	xul.dll 	std::panicking::begin_panic<&str> 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:413
32 	xul.dll 	std::sys::imp::thread_local::create 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys/windows/thread_local.rs:69
33 	xul.dll 	std::sys_common::thread_local::StaticKey::lazy_init 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys_common/thread_local.rs:180
34 	xul.dll 	std::panicking::update_panic_count::PANIC_COUNT::__getit 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/thread/local.rs:163
35 	xul.dll 	std::panicking::rust_panic_with_hook 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:426
36 	xul.dll 	std::panicking::begin_panic<&str> 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:413
37 	xul.dll 	std::sys::imp::thread_local::create 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys/windows/thread_local.rs:69
38 	xul.dll 	std::sys_common::thread_local::StaticKey::lazy_init 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys_common/thread_local.rs:180
39 	xul.dll 	std::panicking::update_panic_count::PANIC_COUNT::__getit 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/thread/local.rs:163
40 	xul.dll 	std::panicking::rust_panic_with_hook 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:426
41 	xul.dll 	std::panicking::begin_panic<&str> 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:413
42 	xul.dll 	std::sys::imp::thread_local::create 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys/windows/thread_local.rs:69
43 	xul.dll 	std::sys_common::thread_local::StaticKey::lazy_init 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys_common/thread_local.rs:180
44 	xul.dll 	std::panicking::update_panic_count::PANIC_COUNT::__getit 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/thread/local.rs:163
45 	xul.dll 	std::panicking::rust_panic_with_hook 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:426
46 	xul.dll 	std::panicking::begin_panic<&str> 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:413
47 	xul.dll 	std::sys::imp::thread_local::create 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys/windows/thread_local.rs:69
48 	xul.dll 	std::sys_common::thread_local::StaticKey::lazy_init 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys_common/thread_local.rs:180
49 	xul.dll 	std::panicking::update_panic_count::PANIC_COUNT::__getit 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/thread/local.rs:163
50 	xul.dll 	std::panicking::rust_panic_with_hook 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:426
51 	xul.dll 	std::panicking::begin_panic<&str> 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:413
52 	xul.dll 	std::sys::imp::thread_local::create 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys/windows/thread_local.rs:69
53 	xul.dll 	std::sys_common::thread_local::StaticKey::lazy_init 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys_common/thread_local.rs:180
54 	xul.dll 	std::panicking::update_panic_count::PANIC_COUNT::__getit 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/thread/local.rs:163
55 	xul.dll 	std::panicking::rust_panic_with_hook 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:426
56 	xul.dll 	std::panicking::begin_panic<&str> 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:413
57 	xul.dll 	std::sys::imp::thread_local::create 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys/windows/thread_local.rs:69
58 	xul.dll 	std::sys_common::thread_local::StaticKey::lazy_init 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys_common/thread_local.rs:180
59 	xul.dll 	std::panicking::update_panic_count::PANIC_COUNT::__getit 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/thread/local.rs:163
60 	xul.dll 	std::panicking::rust_panic_with_hook 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:426
61 	xul.dll 	std::panicking::begin_panic<&str> 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:413
62 	xul.dll 	std::sys::imp::thread_local::create 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys/windows/thread_local.rs:69
63 	xul.dll 	std::sys_common::thread_local::StaticKey::lazy_init 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys_common/thread_local.rs:180
64 	xul.dll 	std::panicking::update_panic_count::PANIC_COUNT::__getit 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/thread/local.rs:163
65 	xul.dll 	std::panicking::rust_panic_with_hook 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:426
66 	xul.dll 	std::panicking::begin_panic<&str> 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:413
67 	xul.dll 	std::sys::imp::thread_local::create 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys/windows/thread_local.rs:69
68 	xul.dll 	std::sys_common::thread_local::StaticKey::lazy_init 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys_common/thread_local.rs:180
69 	xul.dll 	std::panicking::update_panic_count::PANIC_COUNT::__getit 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/thread/local.rs:163
70 	xul.dll 	std::panicking::rust_panic_with_hook 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:426
71 	xul.dll 	std::panicking::begin_panic<&str> 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:413
72 	xul.dll 	std::sys::imp::thread_local::create 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys/windows/thread_local.rs:69
73 	xul.dll 	std::sys_common::thread_local::StaticKey::lazy_init 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys_common/thread_local.rs:180
74 	xul.dll 	std::panicking::update_panic_count::PANIC_COUNT::__getit 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/thread/local.rs:163
75 	xul.dll 	std::panicking::rust_panic_with_hook 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:426
76 	xul.dll 	std::panicking::begin_panic<&str> 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:413
77 	xul.dll 	std::sys::imp::thread_local::create 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys/windows/thread_local.rs:69
78 	xul.dll 	std::sys_common::thread_local::StaticKey::lazy_init 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys_common/thread_local.rs:180
79 	xul.dll 	std::panicking::update_panic_count::PANIC_COUNT::__getit 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/thread/local.rs:163
80 	xul.dll 	std::panicking::rust_panic_with_hook 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:426
81 	xul.dll 	std::panicking::begin_panic<&str> 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:413
82 	xul.dll 	std::sys::imp::thread_local::create 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys/windows/thread_local.rs:69
83 	xul.dll 	std::sys_common::thread_local::StaticKey::lazy_init 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys_common/thread_local.rs:180
84 	xul.dll 	std::panicking::update_panic_count::PANIC_COUNT::__getit 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/thread/local.rs:163
85 	xul.dll 	std::panicking::rust_panic_with_hook 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:426
86 	xul.dll 	std::panicking::begin_panic<&str> 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/panicking.rs:413
87 	xul.dll 	std::sys::imp::thread_local::create 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys/windows/thread_local.rs:69
88 	xul.dll 	std::sys_common::thread_local::StaticKey::lazy_init 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/sys_common/thread_local.rs:180
89 	xul.dll 	std::panicking::update_panic_count::PANIC_COUNT::__getit 	C:/bot/slave/stable-dist-rustc-win-msvc-32/build/src/libstd/thread/local.rs:163
1006 	xul.dll 	mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp:338
1007 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc:231
1008 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc:211
1009 	xul.dll 	nsThread::ThreadFunc(void*) 	xpcom/threads/nsThread.cpp:490
1010 	nss3.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c:397
1011 	nss3.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c:95
1012 	ucrtbase.dll 	_o__CIpow 	
1013 	kernel32.dll 	BaseThreadInitThunk 	
1014 	ntdll.dll 	__RtlUserThreadStart 	
1015 	ntdll.dll 	_RtlUserThreadStart

this rust-related crash signature in the content process is newly showing up on version 53 (so far on 32bit instances of the browser on win7).
in early stability data for 53.0b1 this is amounting to 3.43% of al content crashes
This looks like a dupe of bug 1320134.
Also shows up with RtlFindClearBits in the top stack frame:
bp-8d93b574-5e00-4b94-88a0-131af2170312
Crash Signature: [@ std::sys::imp::thread_local::create] → [@ std::sys::imp::thread_local::create] [@ RtlFindClearBits | RtlFindClearBitsAndSet | TlsAlloc ]
Get Kanru's attention as well. :-)
Flags: needinfo?(kchen)
Flags: needinfo?(kchen)
Whiteboard: [ps-radar]
Hi guys. Please, can you confirm that this is a dupe of Bug 1320134? Thank you.
Flags: needinfo?(ted)
Flags: needinfo?(kchen)
Comment hidden (obsolete)
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Sorry for closing the wrong bug.
(In reply to Vlad Bacia-Mociran [:VladB] from comment #4)
> Hi guys. Please, can you confirm that this is a dupe of Bug 1320134? Thank
> you.

To answer your question, I am 90%+ sure this is a dupe of bug 1320134.
I can track this in the meantime for 53, but it does sound likely to be a duplicate.
tracking-firefox53: --- → +
Any more sure now it's a dup?  THanks
Flags: needinfo?(cyu)
I think this is a dupe. Both are stack ovlerflows, and the signatures in this bug are just symbolicated versions of those in 1320134.
Flags: needinfo?(cyu)
As per comment 7, comment 8 and comment 10 marking this issue as DUPLICATE.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1320134
status-firefox53: affected → fix-optional
status-firefox54: ? → ---
tracking-firefox53: + → -
Moving from Core::Untriaged to Core::General https://bugzilla.mozilla.org/show_bug.cgi?id=1407598
Component: Untriaged → General
You need to log in before you can comment on or make changes to this bug.