[Linux] Graphical issues in Panel Menu when using different values for devPixelsPerPx

RESOLVED WONTFIX

Status

()

Firefox
Toolbars and Customization
RESOLVED WONTFIX
11 months ago
10 months ago

People

(Reporter: bogdan_maris, Unassigned)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(firefox52 affected, firefox53 affected, firefox54 affected, firefox55 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 months ago
Created attachment 8845410 [details]
Screenshot showing the issue

[Affected versions]:
- Firefox 51.0.1
- Firefox 52.0
- Firefox 53 beta 1
- latest Developer Edition 54.0a2
- latest Nightly 55.0a1

[Affected platforms]:
- Ubuntu 16.04

[Steps to reproduce]:
1. Start Firefox
2. Change the value of layout.css.devPixelsPerPx to 1.2, 1.5, 1.75 etc
3. Click on Panel Menu 

[Expected result]:
- Panel menu is displayed without graphical issues.

[Actual result]:
- Panel menu has some serious graphical problems (see screenshot).

[Regression range]:
- This is not a regression, it reproduced back to Nightly from 2013-11-19 where Australis was first enabled (a bit different but graphical issues still can be seen).

[Additional notes]:
- Screenshot showing the issue attached.
(Reporter)

Comment 1

11 months ago
Forgot to say that the displays I used are both FullHD 1920x1080. 

Desktop:
- AMD FX-8320 3.50 GHz CPU
- AMD Radeon HD 6450 GPU
	
Laptop HP ProBook 470 G3 (17''):
- Intel Core i5 6200U 2.4 GHz CPU
- Intel HD 520 and AMD Radeon R7 M340 GPUs

Comment 2

11 months ago
I think this is likely a dupe of bug 1336558. It looks like the GTK theme doesn't honour that pref in the way other OSes do, assuming this is Linux-only.
Component: Theme → Widget: Gtk
Product: Firefox → Core

Updated

11 months ago
See Also: → bug 1336558
This demonstrates only when the menu is shown before changing the value of the pref.
It does not demonstrate when the corresponding menu is opened in new main windows.

It is not a dupe of bug 1336558.

I suspect something is caching a size.
I guess it could be something in widget code, but I think it is more likely layout or frontend.
Component: Widget: Gtk → Menus
Product: Core → Firefox

Comment 4

10 months ago
(In reply to Karl Tomlinson (:karlt) from comment #3)
> This demonstrates only when the menu is shown before changing the value of
> the pref.
> It does not demonstrate when the corresponding menu is opened in new main
> windows.
> 
> It is not a dupe of bug 1336558.
> 
> I suspect something is caching a size.
> I guess it could be something in widget code, but I think it is more likely
> layout or frontend.

Jared, given that this is fine after either a restart or a new window, should we just WONTFIX? Doesn't seem worth investigating in more detail in this case...
Component: Menus → Toolbars and Customization
Flags: needinfo?(jaws)
Yes, we cache the sizes of the menu iirc. However, this pref is only found in about:config and not something that is actually changed often.

I agree with marking this as "wontfix".
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Flags: needinfo?(jaws)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.