stylo: Enable chrome mochitests of style system and enable mochitests on e10s

RESOLVED FIXED in Firefox 55

Status

()

enhancement
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: xidorn, Assigned: xidorn)

Tracking

unspecified
mozilla55
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 fixed)

Details

Attachments

(1 attachment)

There are two browser mochitests and nine chrome mochitests in layout/style/test. We probably want to enable them as well since they are also testing style system.
Blocks: 1346048
Priority: -- → P1
Duplicate of this bug: 1346048
Summary: stylo: Enable browser and chrome mochitests of style system → stylo: Enable browser and chrome mochitests of style system and enable mochitests on e10s
It looks like browser-chrome mochitest doesn't use SimpleTest framework, so integrating failure pattern into them is probably non-trivial. Given that there are only two browser-chrome mochitests, and only one of them is actually testing something new, I'm going to leave it untouched for now.
Summary: stylo: Enable browser and chrome mochitests of style system and enable mochitests on e10s → stylo: Enable chrome mochitests of style system and enable mochitests on e10s
Attachment #8845750 - Flags: review?(glob) → review?(jmaher)
Comment on attachment 8845750 [details]
Bug 1346047 - Enable chrome style system mochitests and run style system mochitests on e10s.

https://reviewboard.mozilla.org/r/118888/#review120960

thanks, this patch is looking good.
Attachment #8845750 - Flags: review?(jmaher) → review+
Thanks for reviewing.
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d8e496463611
Enable chrome style system mochitests and run style system mochitests on e10s. r=jmaher
https://hg.mozilla.org/mozilla-central/rev/d8e496463611
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.