Video Canvas becomes black once there's no more data to be displayed

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: jya, Unassigned)

Tracking

({regression, regressionwindow-wanted})

41 Branch
regression, regressionwindow-wanted
Points:
---

Firefox Tracking Flags

(firefox52 wontfix, firefox53 wontfix, firefox54 wontfix, firefox55 fixed)

Details

(URL)

(Reporter)

Description

2 years ago
This can be seen with this test case:

https://people-mozilla.org/~jyavenard/tests/mse_mp4/1342913/t2.html

When playback reach the end of the buffered data, the canvas become dark and the spinner is shown.

Expected: The last video frame should still be displayed which is frame 46.

Comment 1

2 years ago
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5787d784485e&tochange=bfd82015df48

I was able to narrow down the regression range using mozregression. I've found out that is was working fine between 2015-06-10 - 2015-06-11. Mozregression failed to dig more into this range due to not finding these builds. 
On build 41.0a1 (20150610030209) when running the provided test case video stops at frame 46. 
When running the video on the builds after that date it stops at frame 45 or less.
status-firefox52: --- → wontfix
status-firefox53: --- → affected
status-firefox54: --- → affected
status-firefox55: --- → affected
Version: unspecified → 41 Branch
Too late for a fix for 53. jya do you need more investigation here or is it just general backlog?
status-firefox53: affected → wontfix
status-firefox54: affected → wontfix
Flags: needinfo?(jyavenard)
(Reporter)

Comment 3

2 years ago
Seems to be working in current Nightly. The last frame is still seen, just greyed out.

Don't know about earlier version of FF, if QA could check...
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(jyavenard)
Resolution: --- → WORKSFORME
I'm ok with this as long as it works in 55! Thanks.
status-firefox55: affected → fixed
You need to log in before you can comment on or make changes to this bug.