Complete Theme is automatically disabled after install in [about:addons]

RESOLVED WONTFIX

Status

()

Toolkit
Add-ons Manager
P5
normal
RESOLVED WONTFIX
a year ago
a month ago

People

(Reporter: ValentinaP, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: post57cleanup, triaged)

(Reporter)

Description

a year ago
Steps to reproduce:
1. Install a CT i.e. https://addons.mozilla.org/en-US/firefox/addon/ft-deepdark/?src=cb-dl-users (do not restart the browser after install)
2. Go to "Appearance" tab, from about:addons 
3. Observe CT status

Expected results:
Complete Theme is not disabled.

Actual results:
Complete Theme is disabled.

Notes/Issues:
- a JS warning is displayed in the console: "Signature Verification Error: the signature on this .jar archive is invalid because the certificate used to sign this file has an unrecognized issuer."
- after restart CT is enabled.
Verified on AMO-prod FF52(Win 7).
Video for this issue: https://www.screencast.com/t/dLNSsls5Zb75
Why don't you expect the new theme to be disabled?  Since it is a complete theme, it cannot be applied until the browser is restarted.  Until then, whatever theme was previously active remains enabled and the new one is disabled...
Flags: needinfo?(valentina.peleskei)
(Reporter)

Comment 2

a year ago
Because, I was thinking that CT should behave like "requires restart" extensions.
(Reporter)

Updated

a year ago
Flags: needinfo?(valentina.peleskei)
Okay this is just about the presentation.  Given the imminent removal of complete themes, I don't think its actually worth spending any time on it.
Priority: -- → P5
Whiteboard: post57cleanup, triaged

Comment 4

a month ago
And complete themes are now no longer supported
Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.