Closed Bug 1346201 Opened 6 years ago Closed 5 years ago

CANVAS_WEBGL_ACCL_FAILURE_ID records values using empty keys

Categories

(Core :: Graphics: CanvasWebGL, enhancement, P1)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1283594
Tracking Status
firefox55 --- affected

People

(Reporter: Dexter, Assigned: Dexter)

References

(Blocks 1 open bug)

Details

(Whiteboard: [measurement:client][gfx-noted])

With bug 1334469 we're disallowing using empty keys to record data in Telemetry keyed histograms.

It seems that this histogram is recording values using empty keys (see bug 1334469 comment 20).

For some reason, |accelAngleFailureId| is empty [1] even if it really can't be. We should fix the problem by using a non-empty key here and investigate why and empty key is used in the first place.

[1] - http://searchfox.org/mozilla-central/rev/7cb75d87753de9103253e34bc85592e26378f506/gfx/gl/GLLibraryEGL.cpp#493
Blocks: 1334469
:pchang, can you find someone to take a look?
Flags: needinfo?(howareyou322)
Priority: -- → P3
Whiteboard: [gfx-noted]
(In reply to Alessio Placitelli [:Dexter] from comment #0)
> With bug 1334469 we're disallowing using empty keys to record data in
> Telemetry keyed histograms.
> 
> It seems that this histogram is recording values using empty keys (see bug
> 1334469 comment 20).
> 
> For some reason, |accelAngleFailureId| is empty [1] even if it really can't
> be. We should fix the problem by using a non-empty key here and investigate
> why and empty key is used in the first place.
> 
> [1] -
> http://searchfox.org/mozilla-central/rev/
> 7cb75d87753de9103253e34bc85592e26378f506/gfx/gl/GLLibraryEGL.cpp#493

I didn't see WebGL passed a empty key in [1], it passed 'FEATURE_FAILURE_ACCL_ANGLE_UNKNOWN' when accelAngleFailureId is empty.
What do you mean empty key here?

[1]http://searchfox.org/mozilla-central/rev/7cb75d87753de9103253e34bc85592e26378f506/gfx/gl/GLLibraryEGL.cpp#495
Flags: needinfo?(howareyou322) → needinfo?(alessio.placitelli)
(In reply to Peter Chang[:pchang] from comment #2)
> (In reply to Alessio Placitelli [:Dexter] from comment #0)
> > With bug 1334469 we're disallowing using empty keys to record data in
> > Telemetry keyed histograms.
> > 
> > It seems that this histogram is recording values using empty keys (see bug
> > 1334469 comment 20).
> > 
> > For some reason, |accelAngleFailureId| is empty [1] even if it really can't
> > be. We should fix the problem by using a non-empty key here and investigate
> > why and empty key is used in the first place.
> > 
> > [1] -
> > http://searchfox.org/mozilla-central/rev/
> > 7cb75d87753de9103253e34bc85592e26378f506/gfx/gl/GLLibraryEGL.cpp#493
> 
> I didn't see WebGL passed a empty key in [1], it passed
> 'FEATURE_FAILURE_ACCL_ANGLE_UNKNOWN' when accelAngleFailureId is empty.
> What do you mean empty key here?
> 
> [1]http://searchfox.org/mozilla-central/rev/
> 7cb75d87753de9103253e34bc85592e26378f506/gfx/gl/GLLibraryEGL.cpp#495

Yeah, that's what puzzled me as well. As I mentioned in comment 0, it "can't be" :-(
However, it looks like somehow we're getting some empty strings (i.e. "") as the second argument of Telemetry::Accumulate() calls for this histogram.
They're not super-high in volume, though.
Flags: needinfo?(alessio.placitelli)
This is still unclear why empty key happened, let's keep eye on the histogram data if they are increasing.
Assignee: nobody → alessio.placitelli
Priority: P3 → P2
Whiteboard: [gfx-noted] → [measurement:client][gfx-noted]
Priority: P2 → P1
I think this could have been fixed by bug 1283594, I'll run an analysis job again to make sure empty keys were coming from builds without that fix.
Looks like nightly builds later than bug 1283594 fixed the problem, see bug 1334469 comment 23. Closing this as a dupe.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1283594
You need to log in before you can comment on or make changes to this bug.