plugin.do_JRE_Plugin_Scan do not support version 1.4

VERIFIED WONTFIX

Status

()

VERIFIED WONTFIX
17 years ago
17 years ago

People

(Reporter: bugzilla, Assigned: rubydoo123)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
the code in nsPluginDirServiceProvider:
http://lxr.mozilla.org/seamonkey/source/modules/plugin/base/src/nsPluginDirServiceProvider.cpp#72
has this:
if (::CompareFileTime(&modTime,&curVer) >= 0 && 
  (atof(curKey) >= 1.3) && (atof(curKey) < 1.4))
{

so JRE 1.4 is not supported.

Comment 1

17 years ago
At this time, this is a WONTFIX. Because JRE 1.4 is an XPCOM component and
requires explicit registration with regxpcom. "Scanning" for it, like with JRE
1.3, it not supported and not advised. That may change one day. We also need a
more scalable solution for all plugin installations, not just Java.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 2

17 years ago
v
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

17 years ago
*** Bug 139458 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.