The Chart pie from Statistics view is not loading on BBC or CNN

RESOLVED WORKSFORME

Status

P2
normal
RESOLVED WORKSFORME
2 years ago
4 months ago

People

(Reporter: ciprian_georgiu, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

Trunk
regression
Bug Flags:
qe-verify +

Firefox Tracking Flags

(platform-rel -, firefox52 unaffected, firefox53 unaffected, firefox54 fix-optional, firefox55 wontfix, firefox56 wontfix, firefox57 fix-optional)

Details

(Whiteboard: [netmonitor])

Attachments

(2 attachments)

Created attachment 8846097 [details]
screenshot - chart pie issue.jpg

[Affected versions]:
- latest Nightly 55.0a1 (2017-03-10)
- latest Aurora 54.0a2 (2017-03-10)

[Affected platforms]:
- Windows 10 x64
- Mac OS X 10.11.6
- Ubuntu 16.04 x64 LTS

[Steps to reproduce]:
1. Start Firefox
2. Go to http://www.bbc.com/
3. Open netmonitor (Ctrl + Shift + Q)
4. Pick a request and click on "Start Performance Analysis..." from context menu

[Expected result]:
- The Chart pie is properly loaded showing statistics for the selected request

[Actual result]:
- The Chart pie is not loading

[Regression range]:
Last good revision: c3c9a685ec6e4f30737d1aab76f8c4e70cbb206f
First bad revision: f0ca34823cf787a36ebe5f82fed8142abe3b7b2d
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=c3c9a685ec6e4f30737d1aab76f8c4e70cbb206f&tochange=f0ca34823cf787a36ebe5f82fed8142abe3b7b2d

Looks like the following bug has the changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1336379

[Additional notes]:
- this seems to be reproducible only on sites with many requests like http://cnn.com/ or http://bbc.com/.
- e.g https://www.wikipedia.org/ displays the Chart pie
Has STR: --- → yes
@Ricky: any tips what could be wrong here?

Honza
Flags: qe-verify?
Whiteboard: [netmonitor] → [netmonitor][triage]

Updated

2 years ago
Blocks: 1307743
Flags: qe-verify? → qe-verify+

Updated

2 years ago
Priority: -- → P3
Whiteboard: [netmonitor][triage] → [netmonitor-reserve]
platform-rel: --- → ?
Whiteboard: [netmonitor-reserve] → [netmonitor-reserve][platform-rel-BBC][platform-rel-BBCNews]

Updated

2 years ago
Blocks: 1348737
No longer blocks: 1307743
Priority: P3 → P2
Whiteboard: [netmonitor-reserve][platform-rel-BBC][platform-rel-BBCNews] → [netmonitor] [platform-rel-BBC] [platform-rel-BBCNews]

Updated

2 years ago
platform-rel: ? → -
Whiteboard: [netmonitor] [platform-rel-BBC] [platform-rel-BBCNews] → [netmonitor]
status-firefox54: affected → fix-optional
status-firefox55: affected → wontfix
status-firefox56: --- → wontfix
status-firefox57: --- → fix-optional
Created attachment 8910895 [details]
statistics view.png
I can get the statistics view all fine on both BBC (see screenshot) and CNN with today's Nightly, so I'll close this. Please reopen if you can reproduce it again.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.