JavaScript error: resource://app/modules/ContentCrashHandlers.jsm, line 137: TypeError: WeakMap key must be an object, got undefined

RESOLVED DUPLICATE of bug 1378036

Status

()

Toolkit
Crash Reporting
RESOLVED DUPLICATE of bug 1378036
9 months ago
3 months ago

People

(Reporter: aryx, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Seen in https://treeherder.mozilla.org/logviewer.html#?job_id=83130175&repo=autoland

[task 2017-03-10T22:14:48.006652Z] 22:14:48     INFO - REFTEST TEST-START | file:///home/worker/workspace/build/tests/reftest/tests/layout/reftests/mathml/menclose-5-verticalstrike.html == file:///home/worker/workspace/build/tests/reftest/tests/layout/reftests/mathml/menclose-5-verticalstrike-ref.html
[task 2017-03-10T22:14:48.007224Z] 22:14:48     INFO - REFTEST TEST-LOAD | file:///home/worker/workspace/build/tests/reftest/tests/layout/reftests/mathml/menclose-5-verticalstrike.html | 189 / 1960 (9%)
[task 2017-03-10T22:14:48.037058Z] 22:14:48     INFO - Sandbox: Unexpected EOF, op 0 flags 0302 path /dev/shm/org.chromium.LVQxQW
[task 2017-03-10T22:14:48.206188Z] 22:14:48     INFO - [Parent 1006] WARNING: pipe error (63): Connection reset by peer: file /home/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 346
[task 2017-03-10T22:14:48.207492Z] 22:14:48     INFO - ###!!! [Parent][MessageChannel] Error: (msgtype=0x2C0082,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv
[task 2017-03-10T22:14:48.208719Z] 22:14:48     INFO - JavaScript error: resource://app/modules/ContentCrashHandlers.jsm, line 137: TypeError: WeakMap key must be an object, got undefined
[task 2017-03-10T22:20:18.221803Z] 22:20:18    ERROR - REFTEST ERROR | file:///home/worker/workspace/build/tests/reftest/tests/layout/reftests/mathml/menclose-5-verticalstrike.html | application timed out after 330 seconds with no output
[task 2017-03-10T22:20:18.223108Z] 22:20:18    ERROR - REFTEST ERROR | Force-terminating active process(es).
I've seen this a few times while testing crashes already, I'm not sure when it was introduced but it's definitely been around for a few months at least.
I noticed this error can be triggered reliably when running dom/ipc/tests/test_process_error.xul, I still don't know what's causing it though.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1378036
You need to log in before you can comment on or make changes to this bug.