Closed Bug 1346496 Opened 4 years ago Closed 4 years ago

Thunderbird Reader Pane Toolbar Does not Reflect Current Gtk Theme

Categories

(Thunderbird :: Message Reader UI, defect)

45 Branch
defect
Not set
normal

Tracking

(thunderbird_esr5253+ fixed, thunderbird53 fixed, thunderbird54 fixed, thunderbird55 fixed)

RESOLVED FIXED
Thunderbird 55.0
Tracking Status
thunderbird_esr52 53+ fixed
thunderbird53 --- fixed
thunderbird54 --- fixed
thunderbird55 --- fixed

People

(Reporter: drankinatty, Assigned: Paenglab)

Details

Attachments

(4 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20170301181722

Steps to reproduce:

Simply open Tbird 45.8esr in the default 3-pane (folders, message, reader) config.


Actual results:

The button toolbar for the reader pane (bottom right pane of the normal 3-pane setup) toolbar buttons (e.g. Reply, Reply List, Forward, Archive, Junk, Delete, more..) do not reflect the current theme and look awkward. It appears in the version race forward, someone replaced the traditionally defined toolbar with a GtkBuildable xml list and failed to provide a hook to style the toolbar buttons with the current theme. (See Attachment 1 [details] [diff]) This causes the toolbar to look horribly awkward in an otherwise well designed and themed application.


Expected results:

The toolbar buttons should reflect the current theme and button style. This does not occur. As you can see in attachment 1 [details] [diff] [review], the toolbar buttons are an awkward off-white in an otherwise dark theme, but the menus they access are properly styled with the current theme. This mismatch of theme elements should be fixed.
TB 45 is coming to the end of its life-cycle, TB 52 will be released next week. In the meantime, can you please try with TB 52 beta: https://www.mozilla.org/en-US/thunderbird/channel/
That's by design. We don't use the system buttons because, especially on Linux, every theme has his own button height and different border width. BTW. the buttons in the main toolbar use the same styling, except the borders in normal state.

But yes, the borders are too light.
Attached patch Bug1346496.patchSplinter Review
This patch makes the msgHeaderView-button's border in normal state less prominent by reducing the opacity.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8846288 - Flags: review?(acelists)
Comment on attachment 8846288 [details] [diff] [review]
Bug1346496.patch

Review of attachment 8846288 [details] [diff] [review]:
-----------------------------------------------------------------

I see no difference with the default (white/gray) theme so that must be a good sign:) As I read the patch it just tweaks some transparency so it will become visible when blended with a darker background that will shine through more.

Thanks.
Attachment #8846288 - Flags: review?(acelists) → review+
Attached image headrbuttons with patch
This is how the buttons look with patch applied.
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/cbf7af49eabc6fa153cf7d0da1bc3fd74d689b1b
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 55.0
Comment on attachment 8846288 [details] [diff] [review]
Bug1346496.patch

[Approval Request Comment]
User impact if declined: too prominent header button border with dark themes
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low

The patch applies on aurora and beta with a fuzziness of one line. For ESR I attach a adapted patch because 52 has still the XP rules.
Attachment #8846288 - Flags: approval-comm-beta?
Attachment #8846288 - Flags: approval-comm-aurora?
[Approval Request Comment]
User impact if declined: too prominent header button border with dark themes
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low
Attachment #8847221 - Flags: approval-comm-esr52?
Attachment #8846288 - Flags: approval-comm-beta?
Attachment #8846288 - Flags: approval-comm-beta+
Attachment #8846288 - Flags: approval-comm-aurora?
Attachment #8846288 - Flags: approval-comm-aurora+
Aurora (TB 54):
https://hg.mozilla.org/releases/comm-aurora/rev/4924f4bdd777fdeb59fff28fff31ab7800ee246b

Beta (TB 53):
https://hg.mozilla.org/releases/comm-beta/rev/4c11c1e4d185b31ec596d49542b93207beae9bdd

Please check that the beta apply worked as intended since there were some minor problems applying the patch.
The beta changeset looks good to me.
Attachment #8847221 - Flags: approval-comm-esr52? → approval-comm-esr52+
You need to log in before you can comment on or make changes to this bug.