[responsive design] Breadcrumbs break with narrow width windows. Thread Option Menu Button obscured by overflowing text.

RESOLVED INVALID

Status

P2
normal
RESOLVED INVALID
2 years ago
a year ago

People

(Reporter: John99, Unassigned)

Tracking

Details

(Whiteboard: [li-00138102], URL)

Attachments

(3 attachments)

Created attachment 8846286 [details]
Obscored options icon, garbled breadcrumbs.

User Story
If a window size is reduced from full screen. Not all content intended to be seen in a full screen view will always fit.
If I reduce the size of my Window any content should be truncated or wrapped gracefully.

That does not always happen. It may instead overflow and be displayed over the top of the thread options button.

I attach a screenshot. I tested this in Linux on a particular thread. I have seen similar problems on more than one occasion.
In due course I will test on Windows and other threads. Leaving this unconfirmed for now until I can get reliable STR and confirm it is also seen on Windows.
(Reporter)

Updated

2 years ago
Status: NEW → UNCONFIRMED
Ever confirmed: false
It looks like we turned the breadcrumb trail off at some point. Maybe to address this issue. 

Are you still seeing this John?
Flags: needinfo?(John99-bugs)
(Reporter)

Comment 2

2 years ago
Created attachment 8852012 [details]
still obscured

Thanks for the reply Patrick.
Yes I do see the problem still.

Not sure about breadcrumbs being turned off, but that may be part of the problem that breaks proper  use of Sumo on Mobiles.

If I look at some support questions with long titles I note that the part of the title may be truncated nicely and end in ellipsis. I still see breadcrumbs in full screen view.
As I reduce the screen view size the breadcrumbs may still overflow and obscure the options button. As I reduce the screen size further the breadcrumbs disappear entirely. 

BUT the whole lot disappears so now the options button is not obscured it and the breadcrumbs is gone and not accessible.
That is one of the problems on using Sumo Lithium on Mobile. 

The screenshot is taken looking at 
> https://support.mozilla.org/t5/Firefox/Problems-with-Firefox-auto-vertically-scrolling-up-and-down-on/m-p/1382595#U1382595 

Are you able to reproduce now ?

I imagine this type of issue may not be unique to the support questions it may well affect other communities groups, articles etc.  I definitely think Sumo  Lithium use has problems on mobile. Those will be separate bugs but more serious because after all we support Firefox Android and will be attempting to provide support to those users some of whom may not have or use large screen computers.
Flags: needinfo?(John99-bugs)
Yes, i am seeing it now. There seems to be an area in the responsiveness of that site that breaks the breadcrumb. 

Roland, can you file a case with Lithium?
Flags: needinfo?(rtanglao)
Flags: needinfo?(rtanglao)
Priority: -- → P2
Whiteboard: [li-00138102]

Updated

2 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

2 years ago
Created attachment 8852928 [details]
KBarticle-OptionsObscured.png

This also happens with KB articles when you reduce the window size. I took the attached screenshot on Windows 7 (using Firefox 52) to view the article at https://support.mozilla.org/t5/Install-and-Update/Important-Firefox-is-ending-support-for-Windows-XP-and-Vista/ta-p/31270 

Should the bugzilla component be changed?  It's currently "Contributor and Question Forums".
Component: Contributor and Question Forums → User Experience & Design
QA Contact: nobody
Updated. Thanks Alice.
Summary: Breadcrumbs break bounds on smaller Windows. Thread Option Menu Button obscured by overflowing text. → [responsive desig] Breadcrumbs break bounds on smaller Windows. Thread Option Menu Button obscured by overflowing text.
Summary: [responsive desig] Breadcrumbs break bounds on smaller Windows. Thread Option Menu Button obscured by overflowing text. → [responsive desig] Breadcrumbs break with narrow width windows. Thread Option Menu Button obscured by overflowing text.
Summary: [responsive desig] Breadcrumbs break with narrow width windows. Thread Option Menu Button obscured by overflowing text. → [responsive design] Breadcrumbs break with narrow width windows. Thread Option Menu Button obscured by overflowing text.

Comment 7

a year ago
Resolved INVALID. We aren't moving back to Lithium - see https://blog.mozilla.org/sumo/2017/06/28/important-platform-update/
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.