Firefox crashes when choosing printing properties (Samsung laser printer)

RESOLVED WORKSFORME

Status

()

Toolkit
Printing
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: Kenan, Unassigned)

Tracking

({crash})

52 Branch
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170302120751

Steps to reproduce:

Environment:
Windows 10 64-bit
Firefox 52 64-bit
Samsung ML-2010 printer drivers installed

Open a pdf in Firefox. Choose to print. Click on 'properties'. 100% reproducibility. Only happens in Firefox. Has happened for many versions and never got fixed.


Actual results:

Crash.


Expected results:

Printer properties page should have opened without a crash.
(Reporter)

Comment 1

a year ago
I also have a Canon printer, and its printing properties page does not exhibit the same behaviour.

I've been submitting crash reports under another email the whole time.

Comment 2

a year ago
Do you have a crash report of this issue in about:crashes? If yes, paste the link of the crash report.

In addition, could you give the version number of your printer (you can find that in the properties of the printer driver in run>devmgmt.msc).
Component: Untriaged → Printing
Flags: needinfo?(koenigseggcc)
Keywords: crash
Product: Firefox → Toolkit
(Reporter)

Comment 3

a year ago
The crash ID still appears to be in a queue of some sort? https://crash-stats.mozilla.com/report/index/b1752d51-efaf-4777-8080-48d742170311
Flags: needinfo?(koenigseggcc) → needinfo?(epinal99-bugzilla2)

Comment 4

a year ago
the CR is visible, but I dont think the crash signature will be really useful here.
Flags: needinfo?(epinal99-bugzilla2)
(Reporter)

Comment 5

a year ago
Is there some information I can get for you?
(Reporter)

Updated

a year ago
Flags: needinfo?(epinal99-bugzilla2)

Comment 6

a year ago
Yes, the printer version would be nice.

In addition, do you know if it used to work with previous versions of Firefox. If yes, it's a possible regression that we can narrow down.
Flags: needinfo?(epinal99-bugzilla2)
(Reporter)

Comment 7

a year ago
Samsung ML-2010. It's been broken for a long while at least. Off-hand, I think it used to work around version 20-something.
(Reporter)

Comment 8

a year ago
Reinstalling the driver seems to have fixed this. Perhaps some reference to the driver was broken--is that a Windows issue, or can Firefox somehow handle this? If it's a Windows issue, I'll close this bug.
Flags: needinfo?(epinal99-bugzilla2)
(Reporter)

Comment 9

a year ago
I'll add that Firefox seemed to be the only application that suffered from this issue.

Comment 10

a year ago
Let's close it, reopen it if the issue is back.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(epinal99-bugzilla2)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.