Cannot rename bookmark or change URL

RESOLVED DUPLICATE of bug 51683

Status

SeaMonkey
Bookmarks & History
--
major
RESOLVED DUPLICATE of bug 51683
16 years ago
13 years ago

People

(Reporter: Matthias Falland, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.9+)
Gecko/20020331
BuildID:    2002033108

It is simmilar to bug 51683, but much harder (for me). I've created two
bookmarks to www.versiontracker.com, one for /windows and one for /macosx. But I
cannot
a) rename one of them e.g. to versiontracker windows
b) or give them a different url
That is because I created the /windows-bookmark with creating another
/macosx-bookmark and changing the url after that.
The only way to create this two bookmarks is to file the different locations. I
cannot copy the one bookmark and change it after that. Not the name (like bug
51683), but also not the url. If I change one, the other one is also changed.
Out of that, the copy-paste-way is pretty useless.

Reproducible: Always
Steps to Reproduce:
1. File http://www.versiontracker.com/macosx
2. "Manage Bookmarks ..."
3. Right-click->Copy on that new bookmark
4. Paste to a subfolder
5. Try to change either the url or name of one of them
6. The other will change also
7. Try to delete both, first the "original", second the one in the subfolder
8. The second deletion will not apper until you close and reopen the subfolder
9. That works also with other urls.

Expected Results:  The two bookmarks should become independent if I change the
url, because  as an user I see two files and even I notice not that I change all
other bookmarks when I change one.

Comment 1

16 years ago
Confirmed. Build 2002032921.

The name and URL of one bookmark seems dependent on the other. Deleting one
won't let you delete the other (at least in the manage bookmarks window.)

Strange behaivior indeed.

Comment 2

16 years ago
Confirmed per Comment #1
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
The deletion problem is bug 123549.  Please try to keep it to one issue per 
bug report.

I suspect this is a duplicate of bug 51683.
(Reporter)

Comment 4

16 years ago
Should we enhance bug 51683, because it covers only "Change name for identical
url", and this bug also covers "Change url for identical name" (both is
impossible). In the actual state I dont think 51683 is a dup of this bug.

Comment 5

16 years ago
Matthias, bookmarks are uniquely identified by their URL, not their name (see 
bug 51683 comment #57).

You're seeing this bug because you're creating two bugs with the same URL, 
THEN changing the properties of one of them, hence bug 51683. 

I wasn't able to reproduce this bug using two bookmarks with the same name and 
different URLs.

*** This bug has been marked as a duplicate of 51683 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.