Status

()

Firefox
Untriaged
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: jure.slak, Unassigned)

Tracking

51 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170129005501

Steps to reproduce:

Navigate to a website with a simple <input type="file"> element, such as http://prog.gimvic.org/ACSL/. Click "Browse" and select an arbitrary file (say, a text file named "map.txt"). This also selects the file for upload, because KDE uses single click "open".

I am using Firefox on Manjaro linux with plasma and kwin 5.9.3.


Actual results:

The dialog closed as expected, then firefox froze for 1.5 seconds without the filename appearing in the file upload element. After that firefox segfaulted, all windows and tabs closed. 

I have tried this with different websites (this bug report form as well) and different files, always with the same result. It is not the case when drag and droping files as gmail attachements for example, but if I drag and drop into file input elelemt the result is the same.


Expected results:

The dialog should close and the filename should appear in the box. Later I should be able to upload the file normally.

Comment 1

a year ago
Please follow the steps on http://support.mozilla.com/kb/Firefox%20crashes and report back here. Thanks!
Flags: needinfo?(jure.slak)
(Reporter)

Comment 2

a year ago
My system is up to date as is the "firefox-kde" package I am using. 
The crash happens in safe mode as well. The "about:crashes" page is not available and there are no files
in the ~/.mozilla/firefox/Crash Reports/ folder.

I have foudn a manjaro forum thread describing a similar issue: https://forum.manjaro.org/t/firefox-kde-segfault/16894, suggesting the problem lies in the kde integration layer over firefox. Quoting: 

> it's the suse patch. that is not compatible with the multi process windows of firefox.
> you can disable it if you want. in about:config search and change browser.tabs.remote.autostart to false

After disabling "browser.tabs.remote.autostart" option in about:config, I cannot reproduce the crash.

Comment 3

a year ago
If you're using some "firefox-kde" package which is not provided by Mozilla (and likely includes code changes not provided by Mozilla), please feel free to report the bug to the maintainers of your distribution instead.
Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(jure.slak)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.