Classic theme on OS X needs its own preview image

RESOLVED DUPLICATE of bug 178401

Status

SeaMonkey
Themes
RESOLVED DUPLICATE of bug 178401
16 years ago
9 years ago

People

(Reporter: Chris Casciano, Assigned: Joe Hewitt (gone))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
running 0.9.9 and nightlies both before and after when I am switching themes the
preview image is all ugly & Windows "grey" looking, obviously not reflecting the
white pinstripe look currently used.

classic.jar/skin/classic/global/preview.gif

Should really look something like:

http://placenamehere.com/Mozilla/osx_classic_preview.gif

Comment 1

16 years ago
I think this should be a bug itself, the whole point of the classic theme is to
look "classic" so the theme should have the grayish background, not pinstripe.
(Reporter)

Comment 2

16 years ago
I disagree, the decision to switch to native themeing has been already made and
elsewhere. This is a follow up bug to clean that up.

Your request sounds like you want to reverse that decision & use static grey
elements instead. If that's what you're asking for I think it should be a
totally different bug.

Comment 3

16 years ago
Confirming, but changing slightly.  OS X needs it's own preview; we don't want
to get rid of the old preview altogether.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Classic theme on OS X needs new preview image → Classic theme on OS X needs its own preview image

Comment 4

16 years ago
Created attachment 79112 [details]
OSX  Preview (themes/classic/global/mac/preview.gif)

This is the OS X preview made for bug 135975.  It follows the same conventions
as the other updated previews so it should be used.  However, andreww wants the
default to be the OS 9 version since it's in wider use, so this bug also needs
a patch to get the two builds using separate previews.

Comment 5

16 years ago
That screen shot has pretty ugly fonts, especially the 'k' in "Back" 
and "Bookmarks" and 'R' in "Reload" look bad. That could be bug 134643 but I'm 
not sure.

Comment 6

15 years ago
Since Mac Classic is becoming a port, the OS X preview can become the default
one now.  Folding this bug into bug 178401; someone just needs to get around to
getting it reviewed and checked in.

*** This bug has been marked as a duplicate of 178401 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

15 years ago
I'm a little unsure of what Bug 178401 is trying to accomplish, but if the end
result is that OS X builds of Mozilla have a preview image of the "classic"
theme that looks like the realities of "classic" on OSX then I'm ok with a dupe
here...

Is 178401 Mac specific? Is it trying to fix regressions on all platforms since
Bug 135975? Has it now warped to just "Switch default Mac OS classic theme
preview to the OS X screen shot"?  Some clean up there is suggested.

Comment 8

15 years ago
Bug 178401 is an update of all the theme preview images, originally because
there's no more grippys on the toolbars.  Since all the previews need to be
updated anyway, and since the title is generic ("Changing screenshots of themes
in preferences") we might as well do both changes at once.

What's happening is that now the default Mac theme preview will be for OS X, and
the onus will be on the Mac Classic maintainers to get their own separate
preview if desired.  This is because OS X is now the primary platform, and Mac
Classic has been demoted to a port.
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.