Scrolling Javascript graphic doesn't appear

RESOLVED INVALID

Status

RESOLVED INVALID
17 years ago
14 years ago

People

(Reporter: gnome, Assigned: samir_bugzilla)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9+) Gecko/20020401
BuildID:    2002040103

On our corporate Intranet site, there's a horizontally-scrolling graphic. When the mouse pointer is over it, the graphic stops scrolling and you can click an image to go to that link. This scrolling works fine in Netscape 4.x for Windows and Mac, IE v4 and up on Windows and Mac. In Mozilla, the graphic doesn't even show up at all.

Reproducible: Always
Steps to Reproduce:
Since you can't access the site from outside, not sure what to do. I suspect it's a Javascript problem. It's using the Conveyer Belt slideshow script from http://www.dynamicdrive.com. It's apparently also using an <iLayer><layer> ... </layer></iLayer> tag combo.

Actual Results:  See description.

Expected Results:  Display sideways scrolling graphics and stop scrolling when mouse is over them.

Comment 1

17 years ago
This isn't a bug in Mozilla, it's just that the script is only
written for IE and NN4.x (and as usual with DD, badly written
at that.)

This should be marked as invalid or perhaps changed to
an evangelism bug.

Comment 2

17 years ago
Sev -> Normal.

Agree we should mark INVALID as long as there's no testcase, it must be a
browser sniffing issue or another IE/NS4.x only JavaScript code issue.

Reporter, you should tell your Webmaster to update the script as Dynamic Drive
proposes NS6.x/Mozilla-compatible scripts:
http://www.dynamicdrive.com/dynamicindex2/index.html
Severity: major → normal

Comment 3

16 years ago
no response from reporter for >60 days. resolving INVALID per previous comments.

reporter: if you can provide a testcase for this somehow, please feel free to do
so and to reopen this bug.  thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

16 years ago
Will just have to check it at work. Maybe I'll try save the page, zip that up, and send it. I suspect it's the script - the webmaster had another script up there (for drop down menus) that crashed IE4 with an illegal operation message. Probably got both scripts from the same site. Personally, I dislike the scrolling Javascript graphic, so the fact it doesn't display doesn't bother me. ;-)
(Reporter)

Comment 5

16 years ago
Created attachment 86194 [details]
Webpage with scrolling Javascript that doesn't work

As requested, here's the intranet web site with the scrolling Javascript
graphic that doesn't appear in Mozilla, but displays fine in NS4.x and IE4-6.

Comment 6

16 years ago
Created attachment 86963 [details]
html from the zip file attachment 86194 [details]

Comment 7

16 years ago
just attached the HTML for reference, but it seems fair enough to leave this bug
closed.

the script that does the scrolling contains this:

Conveyor belt slideshow script- 
© Dynamic Drive (www.dynamicdrive.com)
For full source code, 100's more DHTML scripts, and Terms Of Use, visit
dynamicdrive.com

the code checks (with document.all) if it's running in Internet explorer, and if
so uses the IE-specific marquee tag. it then checks (with document.layers) if
it's running in netscape 4.x, and if so uses NS4-specific layers to do the
scrolling.

mozilla isn't going to support the proprietary layers or marquee feature, so the
appropriate solution here would be evangelism - it's not a public site so the
only person that can evangelise are the local users.

David - in the case the above made no sense - this isn't a Mozilla problem, it's
a problem with that page.  If you feel like it, you could tell whoever maintains
your intranet that the scroller code they are using sucks because it's designed
for specific browsers and not web standards.  Thanks for the report anyway :)
(Reporter)

Comment 8

16 years ago
Thanks, I mentioned it to our intranet webmaster. He recited statistics from the server log showing that Mozilla and Netscape versions outside of 4.x show up less than  .5% of visits. IOW, I don't think he's interested in fixing it, because he doesn't consider it a problem.
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.