Scrollbar is not draggable in Style editor (sometimes)

REOPENED
Unassigned

Status

()

Firefox
Developer Tools: Source Editor
P3
normal
REOPENED
a year ago
8 months ago

People

(Reporter: 684sigma, Unassigned)

Tracking

({regression})

51 Branch
regression
Points:
---

Firefox Tracking Flags

(firefox52 wontfix, firefox-esr52 fix-optional, firefox53 wontfix, firefox54 fix-optional, firefox55 fix-optional)

Details

(Reporter)

Description

a year ago
I have a problem with Firefox Release 51. It doesn't happen in Firefox ESR 45.
Sometimes when I drag scrollbar in Style editor, selected style doesn't scroll.
I noticed two specific scenarios when it happens

1. Set dark theme in devtools
2. Open about:config , open Style editor
3. Try to drag scrollbar in Style editor

1. Set dark theme in devtools
2. Open about:config , open Style editor
3. Set light theme in devtools
4. Try to drag scrollbar in Style editor

Result: Scrollbar doesn't move. Text in style is selected
Expected: Text shouldn't be selected. Style should scroll as I drag scrollbar
(Reporter)

Updated

a year ago
Keywords: regression

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1265807
(Reporter)

Comment 2

a year ago
Did you test it? Bug 1265807 is fixed in Firefox 52, yet this bug is reproducible in Firefox Beta 52.
Flags: needinfo?(yfdyh000)
(Reporter)

Comment 3

a year ago
* Only the second scenario is reproducible. It's also reproducible in Firefox Beta 53 (checked both versions)
Which OS are you using?
Flags: needinfo?(684sigma)

Comment 5

a year ago
I see the issue with STR 2 in Fx53b1 on Win10.
Blocks: 1265807
Status: RESOLVED → REOPENED
Has STR: --- → yes
status-firefox52: --- → affected
status-firefox53: --- → affected
status-firefox54: --- → affected
status-firefox55: --- → affected
status-firefox-esr52: --- → affected
Component: Developer Tools: Style Editor → Developer Tools: Source Editor
Ever confirmed: true
Flags: needinfo?(yfdyh000)
Flags: needinfo?(684sigma)
Resolution: DUPLICATE → ---
Gabriel, can you please take a look when you get a chance?
status-firefox52: affected → wontfix
status-firefox-esr52: affected → fix-optional
Flags: needinfo?(gl)
Too late for a fix for 53, minor carryover regression, no one assigned, so these don't seem like a high priority.
status-firefox53: affected → wontfix
status-firefox54: affected → fix-optional
Patrick, maybe you can help find someone to investigate?
Flags: needinfo?(gl) → needinfo?(pbrosset)
I can reproduce STR2 in FF56 an dFF57 on Windows 10. So this is still an issue, and has been for a long time.

I couldn't reproduce it any other way than by following exactly the steps described though. If I switch theme in a different order then the problem doesn't occur.
You really have to have the dark theme selected first, open the style editor, then switch to the light theme, go back to the style editor, and then try to grab the scrollbar with the mouse.

I also noticed that as soon as you start using then mouse wheel, then the problem goes away and you can grab the scrollbar again.
It also goes away if you select another stylesheet in the list.

I'm guessing this is related to our theme switching mechanism and to the floating scrollbars we have in the dark theme (done in devtools\client\themes\floating-scrollbars-dark-theme.css). We might need to force a hard refresh or something like that when switching to the light theme again.

I'm adding this to our backlog as P3, but because it's not a very likely problem to encounter and because there are ways to recover, we're most likely not going to look at this very soon.
I think we can live with this regression and should not be tracking releases here.
status-firefox55: affected → fix-optional
Flags: needinfo?(pbrosset)
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.