Opening the addons manager tab takes several seconds.

RESOLVED WORKSFORME

Status

()

Toolkit
General
--
minor
RESOLVED WORKSFORME
9 months ago
8 months ago

People

(Reporter: Caspy7, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 months ago
(Fairly new computer)
When I hit ctrl + shift + A, it will *sometimes* take several seconds to open the addons manager tab.
If I close the tab and reopen it with the same method it will open immediately.

Here's the Performance profile I took:
https://perfht.ml/2nr9K6x
(Reporter)

Updated

9 months ago
Flags: needinfo?(ehsan)

Comment 1

9 months ago
I have tested the reported behavior and I was able to reproduce it 2 times from 10 attempts on Nightly and not able to reproduce it on Firefox release. I've around 5-7 addons installed. I observed very minor delay for a second or so when opening the addons manager tab for the first time, after that the tab was opened immediately without any delay. 

Chrome needs a 1-2 seconds every time to shown the information about the installed addons.

Could you please retest this using latest FF release and latest Nightly build (https://nightly.mozilla.org/) and report back the results ? When doing this, please use a new clean Firefox profile, maybe even safe mode, to eliminate custom settings as a possible cause (https://goo.gl/PNe90E).
Severity: normal → minor
Flags: needinfo?(caspy77)

Comment 2

9 months ago
I took an extended look at the profile.  The profile is actually pretty good in terms of jank issues, there isn't really too much jank going on here.  Since the Quantum Flow effort is mostly focusing on jank issues for now, I don't think we need to be trackning this for QF.

In terms of latency this is horrible though.  It's hard to figure out the reason behind the latency without knowing about the add-ons manager code.  Perhaps Mossop would be able to have a look?
Component: General → General
Flags: needinfo?(ehsan)
Product: Core → Toolkit
(In reply to Caspy7 from comment #0)
> (Fairly new computer)
> When I hit ctrl + shift + A, it will *sometimes* take several seconds to
> open the addons manager tab.

Can you clarify what you mean here? Do you mean until the tab appears in the tab strip or until the content appears. What section of the add-ons manager does this occur with?
(Reporter)

Comment 4

9 months ago
(In reply to Dave Townsend [:mossop] from comment #3)
> (In reply to Caspy7 from comment #0)
> > (Fairly new computer)
> > When I hit ctrl + shift + A, it will *sometimes* take several seconds to
> > open the addons manager tab.
> 
> Can you clarify what you mean here? Do you mean until the tab appears in the
> tab strip or until the content appears. What section of the add-ons manager
> does this occur with?

It does not seem to matter what section of the addons manager is selected.
The tab is opening, I'm switched to it and for the tab content I'm seeing a blank screen for sometimes multiple seconds. If I have my "dark" Stylish style enabled it will be dark for most of this then turn white then the manager will appear (otherwise it is just white).
(Reporter)

Comment 5

8 months ago
Going to go ahead and close this because I haven't noticed it in a while and iirc I had not reproduced it in safe mode.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Flags: needinfo?(caspy77)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.