free.fr - .qmb file served as text/plain instead of application/octet-stream

VERIFIED DUPLICATE of bug 135411

Status

Tech Evangelism Graveyard
French
--
minor
VERIFIED DUPLICATE of bug 135411
16 years ago
3 years ago

People

(Reporter: Steven Neil Groginsky, Assigned: Tristan Nitot)

Tracking

Details

(Whiteboard: [havefix] [mime-default], URL)

(Reporter)

Description

16 years ago
Is default to text in layout when file type is unknown proper?

In the above url (actually this is the link for <download>, the extension "qmb"
is unknown so the file is downloaded as text in the Mozilla window.  I wouldn't
even know how to add it to helper applications.  Also, I'm surprised that it
even got to the filename because there is no php3 in helper apps, just php.

Comment 1

16 years ago
The php script redirects to 
http://quickmenubuilder.free.fr/menus/Erin%Brockovich.qmb

the server tells us that the file is text/plain
the server is telling us to show it as text

marking it invalid.
the only thing you could do is contact the webmaster of the site and tell him he
should be sending the files with the  correct content-type

Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
reopening

Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
-> Tech evangelism
Assignee: sairuh → nitot
Status: UNCONFIRMED → NEW
Component: Layout → Europe: West
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: petersen → caillon
Version: other → unspecified
(Reporter)

Comment 4

16 years ago
I see this bug has been tagged browser evangelism.  I wonder if there is also a
difference between the way we do things and the way the French are doing things.
 Just a little poke in that direction.  Actually doesn't sound like it from the
last comment.
free.fr is just sending the wrong mime type for this file.
they need to configure their server to send the right one...

Updated

16 years ago
Whiteboard: [havefix]

Comment 6

15 years ago
Contact address is mattgo27@quickmenubuilder.com

The server's default content-type for unknown suffixes is probably text/plain.

% curl -I http://quickmenubuilder.free.fr/menus/Erin%20Brockovich.qmb
HTTP/1.1 200 OK
Date: Sun, 20 Apr 2003 17:06:13 GMT
Server: Apache/1.3.20 (Unix) Debian/GNU
Last-Modified: Sun, 13 Jan 2002 17:27:47 GMT
ETag: "7cca0b-2c117-3c41c393"
Accept-Ranges: bytes
Content-Length: 180503
Content-Type: text/plain
Severity: normal → minor
OS: Windows 98 → All
Hardware: PC → All
Summary: Is default to text in layout when file type is unknown proper? → free.fr - .qmb file served as text/plain instead of application/octet-stream
Whiteboard: [havefix] → [havefix] [mime-default]

*** This bug has been marked as a duplicate of 135411 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → DUPLICATE
tech evang june 2003 reorg
Component: Europe: West → French
verified.
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.