Font rendering: Font is streched, the width differs on different systems

RESOLVED FIXED

Status

()

RESOLVED FIXED
a year ago
10 months ago

People

(Reporter: mg, Unassigned)

Tracking

45 Branch
Points:
---

Firefox Tracking Flags

(firefox-esr52 wontfix, firefox56 unaffected, firefox57 unaffected, firefox58 unaffected)

Details

(Whiteboard: gfx-noted)

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8847149 [details]
firefox-font-rendering.png

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20170301181722

Steps to reproduce:

Loaded our website (http:www.ur.de) on different PCs in Firefox (ESR 45.x).
We have many PCs (>1000) and install these with an image, so we have the same software environment.


Actual results:

A font (Lucida Sans Unicode) on our website is rendered too broad on some PCs - see the attached Image, showing one screen shot with wrong rendering an one with good.
The font-size in relation to the height is identical in every environment (calculated to 16.1 px at 100% scaling) but the width differs about 10%. The font is streched.
As you can see in the screen shots the height of containing element differs too. This difference comes from spacing above and below the letters of the "normal" font.
This happens on circa every 10th PC (also under Windows and Linux both 32 or 64 bit).
The problem is reproduceable. I installed 4 test PCs a couple of times. 2 of them had that problem always, the others were always good. The OS didn't matter (win7, 8,10 32 or 64 bit). And the FF Version of 45x didn't matter (32 or 64 bit).

Updated

a year ago
Component: Untriaged → Graphics: Text
Product: Firefox → Core
The screenshots show a difference between ClearType antialiasing (top) and grayscale (bottom), which results in different hinting and font metrics. This might be related to OS-level preferences (e.g. settings in the Fonts control panel), or -- perhaps more likely -- caused by hardware/driver differences that determine whether hardware graphics acceleration is enabled in Firefox.
(Reporter)

Comment 2

a year ago
Created attachment 8847558 [details]
Photo of three PCs next to each other to show different behaviour
(Reporter)

Comment 3

a year ago
(In reply to Jonathan Kew (:jfkthame) from comment #1)
> The screenshots show a difference between ClearType antialiasing (top) and
> grayscale (bottom), which results in different hinting and font metrics.
> This might be related to OS-level preferences (e.g. settings in the Fonts
> control panel), or -- perhaps more likely -- caused by hardware/driver
> differences that determine whether hardware graphics acceleration is enabled
> in Firefox.

Thank you for your quick reply and your hint about the antialiasing.
I think, what you describe as different interpolation, is a mistake and my fault. I took the screenshots on diffent PCs and copied and pasted them via email and obviously there were some quality losses in the screenshots.

I looked it up. All PCs have ClearType enabled.
I tested to deactivate ClearType and this has no effect.
I took a photo of three test PCs and pasted it.
Is there anything more we can check, :jfkthame?
Flags: needinfo?(jfkthame)
I still believe the original screenshot shows a difference in antialiasing modes. Maybe this is a result of different graphics hardware and/or drivers, causing us to choose the GDI font backend in one case and DirectWrite in the other. If that was the case, then (a) I guess collecting about:support details might help to verify it, but also (b) the behavior may well have changed in recent versions of Firefox, with the move to Skia and DW everywhere (IIUC).

So at this point, I guess the first question is whether the issue still occurs with the current release of Firefox, or has it "magically" been fixed in the meantime?
Flags: needinfo?(jfkthame)
Is this bug still present in Firefox 56 or above?
Flags: needinfo?(mg)
(Reporter)

Comment 7

10 months ago
No. As far as i see the bug is no longer present in 56++.

PS. to (a)
I made a diff on the settings under about:support and there has been no differences.
Flags: needinfo?(mg)
Thanks. I'm going to close this as FIXED then.
Please reopen or comment if you think we missed anything still.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
status-firefox56: --- → unaffected
status-firefox57: --- → unaffected
status-firefox58: --- → unaffected
status-firefox-esr52: --- → wontfix
Resolution: --- → FIXED
Whiteboard: gfx-noted
You need to log in before you can comment on or make changes to this bug.