Closed Bug 1347243 Opened 3 years ago Closed 3 years ago

Mozilla Firefox Nightly 55.0a1 (2017-03-14) (32-bit) crashes in [@ safemon.dll@ ... ] (caused by Qihoo 360 Safe Guard Monitor)

Categories

(External Software Affecting Firefox :: Other, defect, critical)

x86
Windows
defect
Not set
critical

Tracking

(firefox-esr45 unaffected, firefox52 unaffected, firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55 verified)

VERIFIED FIXED
Tracking Status
firefox-esr45 --- unaffected
firefox52 --- unaffected
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- unaffected
firefox55 --- verified

People

(Reporter: Virtual, Assigned: linjinan)

Details

(Keywords: crash, nightly-community, regression)

Crash Data

First appearance - 2017-03-14
Crashlog signature - [@ safemon.dll@0xe19f ]
Caused by - Qihoo 360 Safe Guard Monitor
There are also these signatures - [@ safemon.dll@0xe00f ] & [@ safemon.dll@0x104efa ]
Crash Signature: [@ safemon.dll@0xe19f ] → [@ safemon.dll@0xe00f ] [@ safemon.dll@0xe19f ] [@ safemon.dll@0x104efa ]
OS: Windows 10 → Windows
Summary: Mozilla Firefox 55.0a1 (2017-03-14) (32-bit) crashes in [@ safemon.dll@0xe19f ] (caused by Qihoo 360 Safe Guard Monitor) → Mozilla Firefox 55.0a1 (2017-03-14) (32-bit) crashes in [@ safemon.dll@ ... ] (caused by Qihoo 360 Safe Guard Monitor)
Virtual do you have STR or is this report based entirely on crash-stats?

Looking at https://crash-stats.mozilla.com/report/index/878f764c-55f6-4958-8bc7-b3b5f2170314

That we only have two threads means we're quite early in startup. I loaded a minidump and this is a content process. So at least we're not crashing Firefox itself (at least in the evidence I have so far).
Flags: needinfo?(Virtual)
This report is based entirely on the crash-stats. I don't have the STR. It just bring my attention per the rocket image, so it could be potentially the startup crash.
Flags: needinfo?(Virtual)
Crash Signature: [@ safemon.dll@0xe00f ] [@ safemon.dll@0xe19f ] [@ safemon.dll@0x104efa ] → [@ safemon.dll@0xe00f ] [@ safemon.dll@0xe19f ] [@ safemon.dll@0x104efa ] [@ safemon.dll@0x10519a ]
Crash Signature: [@ safemon.dll@0xe00f ] [@ safemon.dll@0xe19f ] [@ safemon.dll@0x104efa ] [@ safemon.dll@0x10519a ] → [@ safemon.dll@0xe00f ] [@ safemon.dll@0xdfbf] [@ safemon.dll@0xe19f ] [@ safemon.dll@0x104efa ] [@ safemon.dll@0x10519a ]
hi,

Could you provide the test environment?

Is it product '360 Total Security' or the other products?

Thanks a lot.
(In reply to linjinan from comment #4)
> hi,
> 
> Could you provide the test environment?
> 
> Is it product '360 Total Security' or the other products?
> 
> Thanks a lot.

It's batter to provide the version of product, which can help to dig out the problem.

Any dump is good for us as well.
Thanks for looking into it, that was very fast.

Looking on crash statistics, the crash happens with Mozilla Firefox Nightly 55.0a1 (2017-03-14) (32-bit) on Windows 8.1 (32bit) and Windows 10 (32bit).
You can get crashlog reports by clicking 1 of 7 (for now) "Crash Signature:" and go to "Reports" tab.
When you will look on some crashlog report, in the "Modules" tab you can see that the one of the crashing files is safemon.dll with 8.4.0.1390 version.
Crash Signature: [@ safemon.dll@0xe00f ] [@ safemon.dll@0xdfbf] [@ safemon.dll@0xe19f ] [@ safemon.dll@0x104efa ] [@ safemon.dll@0x10519a ] → [@ safemon.dll@0xe00f ] [@ safemon.dll@0xdfbf ] [@ safemon.dll@0xe11f ] [@ safemon.dll@0xe19f ] [@ safemon.dll@0x104efa ] [@ safemon.dll@0x10516a ] [@ safemon.dll@0x10519a ]
Summary: Mozilla Firefox 55.0a1 (2017-03-14) (32-bit) crashes in [@ safemon.dll@ ... ] (caused by Qihoo 360 Safe Guard Monitor) → Mozilla Firefox Nightly 55.0a1 (2017-03-14) (32-bit) crashes in [@ safemon.dll@ ... ] (caused by Qihoo 360 Safe Guard Monitor)
According to the following link:
https://crash-stats.mozilla.com/report/index/37ae2a46-4dcb-46cc-a7a5-602e12170316#tab-rawdump

How can I download the dump? It seems to need more permission even though I signed in.
@ Benjamin Smedberg [:bsmedberg] - Please see comment #7
Flags: needinfo?(benjamin)
Crash Signature: [@ safemon.dll@0xe00f ] [@ safemon.dll@0xdfbf ] [@ safemon.dll@0xe11f ] [@ safemon.dll@0xe19f ] [@ safemon.dll@0x104efa ] [@ safemon.dll@0x10516a ] [@ safemon.dll@0x10519a ] → [@ safemon.dll@0xe00f ] [@ safemon.dll@0xdfbf ] [@ safemon.dll@0xe11f ] [@ safemon.dll@0xe19f ] [@ safemon.dll@0x104efa ] [@ safemon.dll@0x10516a ] [@ safemon.dll@0x10519a ] [@ safemon.dll@0x10274a ]
People who are not Mozilla employees cannot have access to minidumps according to our privacy policy, *unless* we find a particular user who gives us explicit permission to share their own dump file.
Flags: needinfo?(benjamin)
(In reply to Benjamin Smedberg [:bsmedberg] from comment #9)
> People who are not Mozilla employees cannot have access to minidumps
> according to our privacy policy, *unless* we find a particular user who
> gives us explicit permission to share their own dump file.

Could you send our own minidumps to my email if it is permitted.
Much appriciated.
Which minidumps are those? Do you have links to ones you submitted yourself? Did you include your email address when you submitted them?
(In reply to Benjamin Smedberg [:bsmedberg] from comment #11)
> Which minidumps are those? Do you have links to ones you submitted yourself?
> Did you include your email address when you submitted them?

I haven't reproduced it by now. But I would like to get the dump from the link:
https://crash-stats.mozilla.com/report/index/37ae2a46-4dcb-46cc-a7a5-602e12170316#tab-rawdump

I think those dump are retained from your automated testing.
(In reply to linjinan from comment #12)
> (In reply to Benjamin Smedberg [:bsmedberg] from comment #11)
> > Which minidumps are those? Do you have links to ones you submitted yourself?
> > Did you include your email address when you submitted them?
> 
> I haven't reproduced it by now. But I would like to get the dump from the
> link:
> https://crash-stats.mozilla.com/report/index/37ae2a46-4dcb-46cc-a7a5-
> 602e12170316#tab-rawdump
> 
> I think those dump are retained from your automated testing.

Are you sure about the report being from us? I wasn't aware we were doing any automated testing.
Flags: needinfo?(linjinan)
@ linjinan@360.cn - The faster way for you will be installing latest Mozilla Firefox Nightly 55.0a1 (32bit) on Microsoft Windows 8.1/10 (32bit) system and get full complete dump by yourself.
Virtual_ManPL, we haven't seen this crash for a few weeks now. Possibly fixed?
Flags: needinfo?(Virtual)
Probably, so I'm marking as FIXED.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(linjinan)
Flags: needinfo?(Virtual)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.